summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Buchinger <cb-gentoo@guya.de>2018-10-05 13:03:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-07 19:01:48 +0200
commite82f9d8b7a2e375886466f0cf92a1a6292237035 (patch)
tree70c26f19cc7fb6e15db8ca72d9496556c2f1ff39 /dev-cpp/popl
parentdev-cpp/aixlog: New package (diff)
downloadgentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.tar.gz
gentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.tar.bz2
gentoo-e82f9d8b7a2e375886466f0cf92a1a6292237035.zip
dev-cpp/popl: New package
Header-only C++ program options parser library. Needed as dependency for new package media-sound/snapcast Closes: https://bugs.gentoo.org/667796 Signed-off-by: Christian Buchinger <cb-gentoo@guya.de> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp/popl')
-rw-r--r--dev-cpp/popl/Manifest1
-rw-r--r--dev-cpp/popl/metadata.xml20
-rw-r--r--dev-cpp/popl/popl-1.2.0.ebuild29
-rw-r--r--dev-cpp/popl/popl-9999.ebuild29
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-cpp/popl/Manifest b/dev-cpp/popl/Manifest
new file mode 100644
index 000000000000..a19372ed67b4
--- /dev/null
+++ b/dev-cpp/popl/Manifest
@@ -0,0 +1 @@
+DIST popl-1.2.0.tar.gz 12302 BLAKE2B cfe775ef5cd823ce7b6cb651f7f8de6c67d24e5e3b657d13e7b2087f3b9673c11a870adbe2195665f4e2c3c7799c2427020d4e86126090ef845aa6a906c7a825 SHA512 a5d372346dd282f634b1ca92f468588f7069b34a5911a6ea46e5ef33e8e6c360ca13f67bf221555d76c7620c4222694077a74589a1c32bdbc094e64366299609
diff --git a/dev-cpp/popl/metadata.xml b/dev-cpp/popl/metadata.xml
new file mode 100644
index 000000000000..0edc57f0bdfe
--- /dev/null
+++ b/dev-cpp/popl/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cb-gentoo@guya.de</email>
+ <name>Christian Buchinger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <name>Johannes Pohl</name>
+ <email>github@badaix.de</email>
+ </maintainer>
+ <bugs-to>https://github.com/badaix/popl/issues</bugs-to>
+ <remote-id type="github">badaix/popl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/popl/popl-1.2.0.ebuild b/dev-cpp/popl/popl-1.2.0.ebuild
new file mode 100644
index 000000000000..39652fbae851
--- /dev/null
+++ b/dev-cpp/popl/popl-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ program options parser library"
+HOMEPAGE="https://github.com/badaix/popl"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/popl.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/popl/popl-9999.ebuild b/dev-cpp/popl/popl-9999.ebuild
new file mode 100644
index 000000000000..39652fbae851
--- /dev/null
+++ b/dev-cpp/popl/popl-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Header-only C++ program options parser library"
+HOMEPAGE="https://github.com/badaix/popl"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit cmake-utils git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/popl.git"
+ EGIT_BRANCH="develop"
+else
+ inherit cmake-utils
+
+ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake-utils_src_configure
+}