summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-22 18:13:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-22 18:15:06 +0100
commite2b2d69da414535b9f7d625ba639460d10427630 (patch)
tree92b4dc845d32ad38121a39947c32b96675884b7e /dev-cpp/sparsehash
parentsys-libs/libnih: sparc stable wrt bug #570122 (diff)
downloadgentoo-e2b2d69da414535b9f7d625ba639460d10427630.tar.gz
gentoo-e2b2d69da414535b9f7d625ba639460d10427630.tar.bz2
gentoo-e2b2d69da414535b9f7d625ba639460d10427630.zip
dev-cpp/sparsehash: Bump to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-cpp/sparsehash')
-rw-r--r--dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch21
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.3.ebuild15
2 files changed, 29 insertions, 7 deletions
diff --git a/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch b/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch
new file mode 100644
index 000000000000..156a7266eaa7
--- /dev/null
+++ b/dev-cpp/sparsehash/files/sparsehash-2.0.3-fix-docdir.patch
@@ -0,0 +1,21 @@
+* Do not override $(docdir) as part of the GNU conventions
+* Do not install 'COPYING' and 'INSTALL'
+* Install html files using html_ prefix and not doc_ prefix
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,12 +11,11 @@
+ AM_CXXFLAGS = -Wall -W -Wwrite-strings -Woverloaded-virtual -Wshadow
+ endif
+
+-docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+ ## This is for HTML and other documentation you want to install.
+ ## Add your documentation files (in doc/) in addition to these boilerplate
+ ## Also add a TODO file if you have one
+-dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
+- TODO \
++dist_doc_DATA = AUTHORS ChangeLog NEWS README README_windows.txt TODO
++dist_html_DATA = \
+ doc/dense_hash_map.html \
+ doc/dense_hash_set.html \
+ doc/sparse_hash_map.html \
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
index 5fb17a073c6d..cc5f66461a19 100644
--- a/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
+++ b/dev-cpp/sparsehash/sparsehash-2.0.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
+
+inherit autotools
DESCRIPTION="An extremely memory-efficient hash_map implementation"
HOMEPAGE="https://github.com/sparsehash/sparsehash"
@@ -15,10 +17,9 @@ IUSE=""
S=${WORKDIR}/${PN}-${P}
-src_install() {
- default
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-docdir.patch )
- # Installs just every piece
- rm -rf "${ED}/usr/share/doc"
- dohtml doc/*
+src_prepare() {
+ default
+ eautoreconf
}