summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-22 02:12:04 +0000
committerSam James <sam@gentoo.org>2021-01-22 02:12:04 +0000
commit03c51da60150f3aca74b51c40cef93a4ad88d99a (patch)
tree1fdfb0f1091075695e033074287d5eec4c08eb59 /dev-cpp/string-theory
parentsys-process/parallel: bump to 20210122 (diff)
downloadgentoo-03c51da60150f3aca74b51c40cef93a4ad88d99a.tar.gz
gentoo-03c51da60150f3aca74b51c40cef93a4ad88d99a.tar.bz2
gentoo-03c51da60150f3aca74b51c40cef93a4ad88d99a.zip
dev-cpp/string-theory: don't build tests with -Werror
Closes: https://bugs.gentoo.org/766468 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/string-theory')
-rw-r--r--dev-cpp/string-theory/string-theory-3.3.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-cpp/string-theory/string-theory-3.3.ebuild b/dev-cpp/string-theory/string-theory-3.3.ebuild
index 82fb3efef9de..5706dd0292ea 100644
--- a/dev-cpp/string-theory/string-theory-3.3.ebuild
+++ b/dev-cpp/string-theory/string-theory-3.3.ebuild
@@ -16,6 +16,14 @@ KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
+src_prepare() {
+ # Drop -Werror from bundled gtest
+ # bug #766468
+ sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DST_BUILD_TESTS=$(usex test)