summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Henke <Jan.Henke@taujhe.de>2017-11-05 22:53:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-07 10:01:51 +0100
commit100eae3223595fdc8cf82a66f593bed85aac93bf (patch)
tree6e323d443903e322498fd8bb34b3267886d876ed /dev-cpp
parentnet-fs/nfs-utils: Removed old. (diff)
downloadgentoo-100eae3223595fdc8cf82a66f593bed85aac93bf.tar.gz
gentoo-100eae3223595fdc8cf82a66f593bed85aac93bf.tar.bz2
gentoo-100eae3223595fdc8cf82a66f593bed85aac93bf.zip
dev-cpp/gsl: Initial addition
Closes: https://github.com/gentoo/gentoo/pull/6135
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gsl/Manifest1
-rw-r--r--dev-cpp/gsl/gsl-0_pre20171105.ebuild24
-rw-r--r--dev-cpp/gsl/metadata.xml16
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/gsl/Manifest b/dev-cpp/gsl/Manifest
new file mode 100644
index 000000000000..3b53acf9b7e3
--- /dev/null
+++ b/dev-cpp/gsl/Manifest
@@ -0,0 +1 @@
+DIST gsl-0_pre20171105.tar.gz 55870 SHA256 5adc4b4ba53102099f63b898da161469a854d4fd47e90195421fbe8bd8b50352 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a WHIRLPOOL 98e26057646f6be4cc6632901b2b45c5e46218e9048cd64561f7f118ee0e8feadeca3ca66a0b73a36a431b666fe7946c6f864dbcf97296bae3945b2350dcf2e5
diff --git a/dev-cpp/gsl/gsl-0_pre20171105.ebuild b/dev-cpp/gsl/gsl-0_pre20171105.ebuild
new file mode 100644
index 000000000000..78ac010145e7
--- /dev/null
+++ b/dev-cpp/gsl/gsl-0_pre20171105.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/${PN}/tarball/d10ebc6555b627c9d1196076a78467e7be505987 -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( >=dev-cpp/catch-1.11.0 )"
+
+src_configure() {
+ local mycmakeargs=( -DGSL_TEST=$(usex test) )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/gsl/metadata.xml b/dev-cpp/gsl/metadata.xml
new file mode 100644
index 000000000000..57bf76b92106
--- /dev/null
+++ b/dev-cpp/gsl/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@taujhe.de</email>
+ <description>Jan Henke</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Microsoft's implmentation of the Guideline Support Library.</longdescription>
+ <upstream>
+ <remote-id type="github">Microsoft/GSL</remote-id>
+ </upstream>
+</pkgmetadata>