summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-09-27 23:54:26 +0100
committerYixun Lan <dlan@gentoo.org>2023-10-17 05:23:16 +0000
commit175afb224f2898d4766e72f74f7197418fe4fffb (patch)
tree3b2d553cb8e7fffef21799f34a7d4d3d529d3656 /dev-cpp
parentmedia-tv/plex-media-server: Stabilize 1.32.5.7516 arm64, #915862 (diff)
downloadgentoo-175afb224f2898d4766e72f74f7197418fe4fffb.tar.gz
gentoo-175afb224f2898d4766e72f74f7197418fe4fffb.tar.bz2
gentoo-175afb224f2898d4766e72f74f7197418fe4fffb.zip
dev-cpp/asio: add 1.28.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.28.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 8ca0a5922c4c..a23cf68c2972 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,4 @@
DIST asio-1.24.0.tar.bz2 3150924 BLAKE2B 4c9b913452fd4288684020ca58b48e22745a39c6a0d682ba84ff561b94c695dc6f5203ed06817f4dd0b9098ea3012578f7c6b2f251b3857e660b0c222dbc003e SHA512 c877968229bc5c4c21156b2bbb9775c7b11c3878cd62e8df3afaa70b2f221c59c6e4fa425cfb028cd170f9453ac1c32c5229f89437b13ac39142e4b52304c820
DIST asio-1.26.0.tar.bz2 3201833 BLAKE2B a42297b448423984143ff8e6a1dcc965f0ef0582e1609c1d51331f1e3d86c96ef9caf9daad36222104f95210ee84a3a59c50b28cb8985b6387a30db690d91b27 SHA512 3e41f71a4e0c6928ec9b9fa1b43b5db3eff21d330de6f6def60deacda79632ded3c4d2b2ffe1ae3fe756ba73e37fac30ecd76a76e1e52067e337cd0e7c9260e7
DIST asio-1.28.0.tar.bz2 3387977 BLAKE2B dc0431a6710f58ce037d6e6e1cf81606b6f8be3ac9fdf6f7a69a7998fadb4f3c9dace2aa99606a9570166f9637ca7f4b9ab6964599c78027a9f32a9d243d5684 SHA512 b3fa23caa4cbf1e374fade97102adb22a32c68bd4b050474987c065b516fdf042d46842c41ac94e71458f402fae2d05bc8f617ee523ffb6a74ef33d214e9acd5
+DIST asio-1.28.1.tar.bz2 3383257 BLAKE2B 9d98152a6cf8b0e2a807275092b23f6198d8175fd7260499be7561cea2e6723c1a8478107315b7163cdc31d6eecab552550393ab3b1cfb686dcb4157d1e91fe4 SHA512 fadd7748675743ba9110f873bf57f2400a5c9c0dc03c1d6cd7f0988bc70ccbbff6cb6140f5dd236d2d874fc82a6f216406e8892808e915aae5119fe9d95743de
diff --git a/dev-cpp/asio/asio-1.28.1.ebuild b/dev-cpp/asio/asio-1.28.1.ebuild
new file mode 100644
index 000000000000..f11d6fe751c9
--- /dev/null
+++ b/dev-cpp/asio/asio-1.28.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_configure() {
+ # By default it puts .pc to libdir
+ econf --with-pkgconfigdir="${EPREFIX}/usr/share/pkgconfig"
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+
+ # Make links to the example .cpp files work
+ # https://bugs.gentoo.org/828648
+ if use doc; then
+ dosym ../examples /usr/share/doc/${PF}/src/examples
+ fi
+ fi
+}