summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-02 08:59:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-02 09:11:11 +0100
commit198521985376c0df398134060aafa42727f46d17 (patch)
tree8e4832d05806152c9d0f90f8c4b94d0bef333b64 /dev-cpp
parentx11-terms/guake: keyword 3.8.1 for ~ppc64 (diff)
downloadgentoo-198521985376c0df398134060aafa42727f46d17.tar.gz
gentoo-198521985376c0df398134060aafa42727f46d17.tar.bz2
gentoo-198521985376c0df398134060aafa42727f46d17.zip
dev-cpp/eigen: Drop 3.3.9
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/eigen/Manifest1
-rw-r--r--dev-cpp/eigen/eigen-3.3.9.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/dev-cpp/eigen/Manifest b/dev-cpp/eigen/Manifest
index c696a730c0d1..3955c4711b20 100644
--- a/dev-cpp/eigen/Manifest
+++ b/dev-cpp/eigen/Manifest
@@ -1,2 +1 @@
-DIST eigen-3.3.9.tar.gz 2142379 BLAKE2B 437dc190fdf7a416d0a5cf81703ef4cc73c195f0f3e7c853e0ab38cf904608ddd4485cc4e15eb0cd5e3c401276f270f3c86f538f205cc91b8c83e131d1bc916d SHA512 16244cc89f2e1879543232b965cbf653b3ccf10e967c8c437a41e27d8320392bdf584d8c24b8a97406ab7d1481d5154da74e0702ec1334ae6a46de83f4573a46
DIST eigen-3.4.0.tar.gz 2705005 BLAKE2B ae5f774a6ed36f52cf9fc3206e50796abacbba69fd0f67cd5759b4e04d847aa656861d5e06e6cd0d798a17f2b06abdb70b16f795a626bdd29edcc872c33821f8 SHA512 ba75ecb760e32acf4ceaf27115468e65d4f77c44f8d519b5a13e7940af2c03a304ad433368cb6d55431f307c5c39e2666ab41d34442db3cf441638e51f5c3b6a
diff --git a/dev-cpp/eigen/eigen-3.3.9.ebuild b/dev-cpp/eigen/eigen-3.3.9.ebuild
deleted file mode 100644
index 6d4b9b345248..000000000000
--- a/dev-cpp/eigen/eigen-3.3.9.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-FORTRAN_NEEDED="test"
-inherit cmake cuda fortran-2
-
-DESCRIPTION="C++ template library for linear algebra"
-HOMEPAGE="https://eigen.tuxfamily.org/index.php?title=Main_Page"
-SRC_URI="https://gitlab.com/lib${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="3"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_ppc_vsx cuda debug doc openmp test" #zvector
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( virtual/pkgconfig )
-"
-DEPEND="
- cuda? ( dev-util/nvidia-cuda-toolkit )
- test? (
- dev-libs/gmp:0
- dev-libs/mpfr:0
- media-libs/freeglut
- media-libs/glew
- sci-libs/adolc[sparse]
- sci-libs/cholmod
- sci-libs/fftw:3.0
- sci-libs/pastix
- sci-libs/scotch
- sci-libs/spqr
- sci-libs/superlu
- sci-libs/umfpack
- virtual/opengl
- )
-"
-# Missing:
-# METIS-5
-# GOOGLEHASH
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.7-gentoo-cmake.patch
- "${FILESDIR}"/${PN}-3.3.9-max-macro.patch
-)
-
-src_prepare() {
- cmake_src_prepare
-
- cmake_comment_add_subdirectory demos
-
- if ! use test; then
- sed -e "/add_subdirectory(test/s/^/#DONOTCOMPILE /g" \
- -e "/add_subdirectory(blas/s/^/#DONOTCOMPILE /g" \
- -e "/add_subdirectory(lapack/s/^/#DONOTCOMPILE /g" \
- -i CMakeLists.txt || die
- fi
-
- use cuda && cuda_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKEPACKAGE_INSTALL_DIR=$(get_libdir)/cmake/${PN}${SLOT}
- )
- use test && mycmakeargs+=(
- # the OpenGL testsuite is extremely brittle, bug #712808
- -DEIGEN_TEST_NO_OPENGL=ON
- # the cholmod tests are broken and always fail
- -DCMAKE_DISABLE_FIND_PACKAGE_Cholmod=ON
- -DEIGEN_TEST_CXX11=ON
- -DEIGEN_TEST_NOQT=ON
- -DEIGEN_TEST_ALTIVEC=$(usex cpu_flags_ppc_altivec)
- -DEIGEN_TEST_CUDA=$(usex cuda)
- -DEIGEN_TEST_OPENMP=$(usex openmp)
- -DEIGEN_TEST_NEON64=$(usex cpu_flags_arm_neon)
- -DEIGEN_TEST_VSX=$(usex cpu_flags_ppc_vsx)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile doc
- HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
- if use test; then
- cmake_src_compile blas
- cmake_src_compile buildtests
-
- # tests generate random data, which
- # obviously fails for some seeds
- export EIGEN_SEED=712808
- fi
-}