summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-02-06 15:14:42 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 20:25:20 -0500
commit1e047c4cb31c15757008bd7253334f30caf96df7 (patch)
treed8aff15ade4f5f2d9d238275e4621a36c676c9e2 /dev-cpp
parentdev-cpp/cairomm: Update slot 0 to version 1.14.2 (diff)
downloadgentoo-1e047c4cb31c15757008bd7253334f30caf96df7.tar.gz
gentoo-1e047c4cb31c15757008bd7253334f30caf96df7.tar.bz2
gentoo-1e047c4cb31c15757008bd7253334f30caf96df7.zip
dev-cpp/pangomm: Update slot 1.4 to version 2.42.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.42.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index bbc346c09c5d..36643b7d4439 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1 +1,2 @@
DIST pangomm-2.42.1.tar.xz 882508 BLAKE2B 34b6a93d931e1a27c7859e3cc407c714588890122639a61d30d9886bc3d861f11e1fcb97a08b6be8bddcde776d86f8b6c4cdc4a53da245ea1dc81f50d402303c SHA512 46ba375e61dd32e268397ecb8e69364b642ea3d9a6c4d9e3e52500e1e1c9fa0c6aa822c6d5046f49a2fe4d9a872c6c2b354134d39c17370abcfc6a1d752223b0
+DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
diff --git a/dev-cpp/pangomm/pangomm-2.42.2.ebuild b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
new file mode 100644
index 000000000000..439b237a3a0a
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.42.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson multilib-minimal
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.2.2:0[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.48.0:2[doc?,${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:2[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.41.0[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}