summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-12-04 10:23:31 -0500
committerCraig Andrews <candrews@gentoo.org>2017-12-04 10:23:54 -0500
commit5296aaeb02019af2a01ac80871e7c5a64585bfb1 (patch)
tree86d990b29eb7779ac4287ed3abf3d737538ce1e9 /dev-cpp
parentsys-power/powertop: remove warning from dead code (diff)
downloadgentoo-5296aaeb02019af2a01ac80871e7c5a64585bfb1.tar.gz
gentoo-5296aaeb02019af2a01ac80871e7c5a64585bfb1.tar.bz2
gentoo-5296aaeb02019af2a01ac80871e7c5a64585bfb1.zip
dev-cpp/waylandpp: 0.1.6 version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.1.6.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index 2bf3409846ba..64ae534e52cc 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -2,3 +2,4 @@ DIST waylandpp-0.1.0.tar.gz 166427 BLAKE2B eef7f14df491e053f2c8cb63aaafc9e9251af
DIST waylandpp-0.1.2.tar.gz 166624 BLAKE2B 8136fb8c7ece2a2ce9d93bd833dbc9c604c47dfd27b17cda60b0c5894d4aada7761e220d9cabf8e5107115e00d2d16fd99a098dac9be6614926b428ea234d788 SHA512 2304390be26134561fb69e208a6bafd0e9789e6b212ff2f46384c6ed50ae1c9eca3f06a3b4958c8e710cc1a0be61ed84c7ff292ec7011dbb0396cd2d83363f7f
DIST waylandpp-0.1.4.tar.gz 168409 BLAKE2B 43811051f1c4cf8795c63d24c54f6f3fac59bf4a482b9dd0f3e2645272475abc732a44330e08449e34f67aa90224382d18ffb0e6f52d9f250685813186ad6e97 SHA512 3f2e9bca0776c02ec3b7a4f76a34214333e0663e2ab81d81cfbc37e1f14bda47e16b3840386b961d47ca993207b0b9f4d4859b621f22fe4e3653c4b14842e001
DIST waylandpp-0.1.5.tar.gz 168432 BLAKE2B 0d3efcb489a713be1ae9db0366b47436b0789468b956ac781f981b3bf1feaebdf2be083f6d1263190e202a45e4416d2d972ffc67d8b87115146f14a5c4af41a5 SHA512 bce1f29607fe61f4b8464abc6111121e3c18777d2e982f143b33087d53af58e9d3a61e412c46dbe73d8cbbaa889da806978e9b3854ce01db8feb53d777625a6f
+DIST waylandpp-0.1.6.tar.gz 180123 BLAKE2B 552dbea6b6d9c3f937aa56a69c90485f6946366589793e53817bada7b2dc1eca0c58a741b22f5f0f7fac04bb14d668f01a1c2418343ebf32845dc1bf02656957 SHA512 93ed7157017394f7df0d7cdf2f56e1d8621893cc8cb77b01206534b8ca40528aba6bd2b922b359809bdca7831fa45668f85903e9e3dd6f0759839c7318349c94
diff --git a/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild b/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild
new file mode 100644
index 000000000000..e8100f35eb98
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils versionator
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ cmake-utils_src_configure
+}