summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-02 10:45:14 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-03-02 12:47:20 +0100
commit52ec8054d103dbbe2789e3641d6f5e5f54fac783 (patch)
tree852c7a61bdaaf5c2fd9f92c8f14846a80e22480b /dev-cpp
parentmedia-libs/libheif: Sync live ebuild (diff)
downloadgentoo-52ec8054d103dbbe2789e3641d6f5e5f54fac783.tar.gz
gentoo-52ec8054d103dbbe2789e3641d6f5e5f54fac783.tar.bz2
gentoo-52ec8054d103dbbe2789e3641d6f5e5f54fac783.zip
dev-cpp/aixlog: Bump to 1.5.0
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/aixlog/Manifest1
-rw-r--r--dev-cpp/aixlog/aixlog-1.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/aixlog/Manifest b/dev-cpp/aixlog/Manifest
index d00ffa40f82c..df45339f20bc 100644
--- a/dev-cpp/aixlog/Manifest
+++ b/dev-cpp/aixlog/Manifest
@@ -1 +1,2 @@
DIST aixlog-1.4.0.tar.gz 13262 BLAKE2B 6be17305e7de95b10bb2c8f0019e235bff9596e33c4fba341cfb4e6e0732330932f2b64be916e57fc0e49197931076701a00df7a305420c938630d6b5786080b SHA512 ec4f5a3902858ad979de8cfa81275951af73c4d159a2615a85cf60fe876ea283864f854b26198bea83c4a568948db82c5e50783c868bd2f6d8427d319b912d6f
+DIST aixlog-1.5.0.tar.gz 14080 BLAKE2B 20042e44853da950cae80787e8b9692635f0935ff0b559054faaf6ac41db4de7ddef1ab071b4244f1338b81fa559ee9445aa643050f9e250587cbbc0aae5db3e SHA512 28556feac1fa804b8a4dc047471e0a6d4c4fb7d81487810d55b09dd1be878246b8bf9f2097b76a980284318823c287bd0a93dd7a3124425a1ea9aced757152b6
diff --git a/dev-cpp/aixlog/aixlog-1.5.0.ebuild b/dev-cpp/aixlog/aixlog-1.5.0.ebuild
new file mode 100644
index 000000000000..bd6ee183403c
--- /dev/null
+++ b/dev-cpp/aixlog/aixlog-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Header-only C++ logging library"
+HOMEPAGE="https://github.com/badaix/aixlog"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
+
+ cmake_src_configure
+}