summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-10 18:22:47 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 20:25:17 -0500
commit54e8407c58fa834e1fa24602623bc076fe84be48 (patch)
tree20a6607bd3107a6038809fe20e628ae0b9800e8e /dev-cpp
parentdev-cpp/glibmm: Fix slot 2.68 (diff)
downloadgentoo-54e8407c58fa834e1fa24602623bc076fe84be48.tar.gz
gentoo-54e8407c58fa834e1fa24602623bc076fe84be48.tar.bz2
gentoo-54e8407c58fa834e1fa24602623bc076fe84be48.zip
dev-cpp/atkmm: Version bump to 2.36.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/atkmm/Manifest1
-rw-r--r--dev-cpp/atkmm/atkmm-2.36.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/atkmm/Manifest b/dev-cpp/atkmm/Manifest
index 9cd32326a8eb..c0e05a6f0a3e 100644
--- a/dev-cpp/atkmm/Manifest
+++ b/dev-cpp/atkmm/Manifest
@@ -1 +1,2 @@
DIST atkmm-2.28.0.tar.xz 891904 BLAKE2B 8172effa5f4dc542020b58d7e3d3bea66b0affa98db977e94249dfd8fa6c4fdea88cabb385dcfdb2d79874017c4e648a737413bae021121d1423d62e335d2737 SHA512 8457cff58648c3d3944d6a9fb400062985c70a714856a5d84d4553cb6b1202bdc47aa48c612851fea1cc1b7ab59381116c65d2a22212907e3c4b7090601946bc
+DIST atkmm-2.36.0.tar.xz 735400 BLAKE2B d8b821fdddd27d10f1995aa6bb8ab8a2ccc3357c7553656e30ee45e4ad677457b7a64a86ee9511124547c1680b5f95c3fd306fb315f3911787a6f0817ca5e130 SHA512 8527dfa50191919a7dcf6db6699767352cb0dac800d834ee39ed21694eee3136a41a7532d600b8b3c0fcea52da6129b623e8e61ada728d806aa61fdc8dc8dedf
diff --git a/dev-cpp/atkmm/atkmm-2.36.0.ebuild b/dev-cpp/atkmm/atkmm-2.36.0.ebuild
new file mode 100644
index 000000000000..8bfb21fbb0db
--- /dev/null
+++ b/dev-cpp/atkmm/atkmm-2.36.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson multilib-minimal
+
+DESCRIPTION="C++ interface for the ATK library"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/glibmm-2.68.0:2[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.18.0[${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:3[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}