summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-03-01 18:43:36 +0100
committerAaron Bauman <bman@gentoo.org>2019-03-03 22:12:33 -0500
commit60b7bb8f79cd906d25dcd34b3eb96c92b97052ff (patch)
tree85c38946ff3b89ba9cfb7310b56a2b3c6d802c93 /dev-cpp
parentsci-physics/root: remove unused patch (diff)
downloadgentoo-60b7bb8f79cd906d25dcd34b3eb96c92b97052ff.tar.gz
gentoo-60b7bb8f79cd906d25dcd34b3eb96c92b97052ff.tar.bz2
gentoo-60b7bb8f79cd906d25dcd34b3eb96c92b97052ff.zip
dev-cpp/catch: remove unused patches
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11198 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-python-automagic.patch25
-rw-r--r--dev-cpp/catch/files/catch-2.2.2-test-python3.patch44
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch b/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
deleted file mode 100644
index ecc99905d7f0..000000000000
--- a/dev-cpp/catch/files/catch-2.2.2-python-automagic.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -308,6 +308,9 @@
-
- include(CTest)
-
-+# Approval tests require python 2.7 or 3
-+find_package(PythonInterp)
-+
- if (BUILD_TESTING AND NOT_SUBPROJECT)
- add_executable(SelfTest ${TEST_SOURCES} ${IMPL_SOURCES} ${REPORTER_SOURCES} ${SURROGATE_SOURCES} ${HEADERS})
- target_include_directories(SelfTest PRIVATE ${HEADER_DIR})
-@@ -384,7 +387,11 @@
- set_tests_properties(NoTest PROPERTIES PASS_REGULAR_EXPRESSION "No test cases matched")
-
- # AppVeyor has a Python 2.7 in path, but doesn't have .py files as autorunnable
-- add_test(NAME ApprovalTests COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
-+ if(NOT ${PYTHONINTERP_FOUND})
-+ message(FATAL_ERROR "Python not found, but required for running tests!")
-+ endif()
-+
-+ add_test(NAME ApprovalTests COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/scripts/approvalTests.py $<TARGET_FILE:SelfTest>)
- set_tests_properties(ApprovalTests PROPERTIES FAIL_REGULAR_EXPRESSION "Results differed")
-
- if (CATCH_USE_VALGRIND)
diff --git a/dev-cpp/catch/files/catch-2.2.2-test-python3.patch b/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
deleted file mode 100644
index 0712f1577077..000000000000
--- a/dev-cpp/catch/files/catch-2.2.2-test-python3.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From dc6b83bec9bdcc149db08711cc9dfd555a8620fa Mon Sep 17 00:00:00 2001
-From: Tom Hughes <tom@compton.nu>
-Date: Fri, 6 Apr 2018 13:59:08 +0100
-Subject: [PATCH] Support Python3 in approval tests
-
----
- scripts/approvalTests.py | 15 +++++++++++----
- 1 file changed, 11 insertions(+), 4 deletions(-)
-
-diff --git a/scripts/approvalTests.py b/scripts/approvalTests.py
-index a2ab5d5a2..16cc7b7d2 100755
---- a/scripts/approvalTests.py
-+++ b/scripts/approvalTests.py
-@@ -72,10 +72,17 @@
-
- overallResult = 0
-
-+def openFile(file, mode):
-+ try:
-+ return open(file, mode, encoding='utf-8', errors='surrogateescape')
-+ except TypeError:
-+ import io
-+ return io.open(file, mode, encoding='utf-8', errors='surrogateescape')
-+
- def diffFiles(fileA, fileB):
-- with open(fileA, 'r') as file:
-+ with openFile(fileA, 'r') as file:
- aLines = [line.rstrip() for line in file.readlines()]
-- with open(fileB, 'r') as file:
-+ with openFile(fileB, 'r') as file:
- bLines = [line.rstrip() for line in file.readlines()]
-
- shortenedFilenameA = fileA.rsplit(os.sep, 1)[-1]
-@@ -139,8 +146,8 @@ def approve(baseName, args):
- subprocess.call(args, stdout=f, stderr=f)
- f.close()
-
-- rawFile = open(rawResultsPath, 'r')
-- filteredFile = open(filteredResultsPath, 'w')
-+ rawFile = openFile(rawResultsPath, 'r')
-+ filteredFile = openFile(filteredResultsPath, 'w')
- for line in rawFile:
- filteredFile.write(filterLine(line).rstrip() + "\n")
- filteredFile.close()