summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-01-30 17:11:21 -0500
committerCraig Andrews <candrews@gentoo.org>2022-01-30 17:12:10 -0500
commit742753ca4cb1e6d2513761c8c46e8c27bb076d73 (patch)
treeb5a611eee1572ba1bceb0b361c72b1835a2d0212 /dev-cpp
parentdev-java/openjdk-bin: add apple silicon version for macos (untested) (diff)
downloadgentoo-742753ca4cb1e6d2513761c8c46e8c27bb076d73.tar.gz
gentoo-742753ca4cb1e6d2513761c8c46e8c27bb076d73.tar.bz2
gentoo-742753ca4cb1e6d2513761c8c46e8c27bb076d73.zip
dev-cpp/waylandpp: 0.2.9 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/waylandpp/Manifest1
-rw-r--r--dev-cpp/waylandpp/waylandpp-0.2.9.ebuild41
-rw-r--r--dev-cpp/waylandpp/waylandpp-9999.ebuild4
3 files changed, 44 insertions, 2 deletions
diff --git a/dev-cpp/waylandpp/Manifest b/dev-cpp/waylandpp/Manifest
index 7663d46aab09..b8e4e9b2f156 100644
--- a/dev-cpp/waylandpp/Manifest
+++ b/dev-cpp/waylandpp/Manifest
@@ -1 +1,2 @@
DIST waylandpp-0.2.8.tar.gz 181950 BLAKE2B 186515308d2e17e39e61f953fcf43df6bcff45a965d6425ffb71f0314fc091d241a975d0e7a61e988091ae7491cab56e163b6bccc0a2584b79b5bd5a7f8573fd SHA512 bf1b8a9e69b87547fc65989b9eaff88a442d8b2f01f5446cef960000b093390b1e557536837fbf38bb6d9a4f93e3985ea34c3253f94925b0f571b4606c980832
+DIST waylandpp-0.2.9.tar.gz 187141 BLAKE2B 0bf1bf62ccc792444d21941f15b675c9584822485c9869b66c40bcddbaac5716dcc25bf98e6110fc549f5f10c1197c9e5188c72b10cb878ba8e133a0e55b2db8 SHA512 abe683c236f3b082fb1bd64ce9cc93e4362040f41b31a42971a280fadc8a7ef06a47c6a02cb5201a3f4f864ccdc8a113a8d9a855ca99b42bf1fc322e2593648f
diff --git a/dev-cpp/waylandpp/waylandpp-0.2.9.ebuild b/dev-cpp/waylandpp/waylandpp-0.2.9.ebuild
new file mode 100644
index 000000000000..ebd06ba3c06a
--- /dev/null
+++ b/dev-cpp/waylandpp/waylandpp-0.2.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Wayland C++ bindings"
+HOMEPAGE="https://github.com/NilsBrause/waylandpp"
+
+LICENSE="MIT"
+IUSE="doc"
+SLOT="0/$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/NilsBrause/waylandpp.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-libs/wayland-1.11.0
+ media-libs/mesa[wayland]
+ >=dev-libs/pugixml-1.9-r1
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+ "
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/waylandpp/waylandpp-9999.ebuild b/dev-cpp/waylandpp/waylandpp-9999.ebuild
index 6fda559666cb..ebd06ba3c06a 100644
--- a/dev-cpp/waylandpp/waylandpp-9999.ebuild
+++ b/dev-cpp/waylandpp/waylandpp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/NilsBrause/waylandpp/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
RDEPEND="