summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-17 18:54:53 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-17 22:47:09 -0500
commit9db419d290d931d05e4bef7cd0305ac88fa532a1 (patch)
tree2289d6971cbb5d774d72535757e6a02c00b2e7e3 /dev-cpp
parentx11-libs/pango: Version bump to 1.50.2 (diff)
downloadgentoo-9db419d290d931d05e4bef7cd0305ac88fa532a1.tar.gz
gentoo-9db419d290d931d05e4bef7cd0305ac88fa532a1.tar.bz2
gentoo-9db419d290d931d05e4bef7cd0305ac88fa532a1.zip
dev-cpp/pangomm: Version bump to 2.50.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/pangomm-2.50.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
index 3fdd6184d2bc..77711bcf8458 100644
--- a/dev-cpp/pangomm/Manifest
+++ b/dev-cpp/pangomm/Manifest
@@ -1,2 +1,3 @@
DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
DIST pangomm-2.48.1.tar.xz 675452 BLAKE2B bb012fc5cb66d5cb98f522e3706fdd35bcc5692fcd942f86ee1e20116590ceca26874c5a58bd3f8fac4f154700dfb37ea060747a6c3069e67adf83ba551e7abc SHA512 c204a1cb7a404f055d62880a760716c5567a835ca495cc5e01589ed59fabb332490e529de716c3438cefbc4428c025d6d01c71e4412b2843e3ab3a3175ccc2f4
+DIST pangomm-2.50.0.tar.xz 753592 BLAKE2B 0db7d43fe2d23e4cfc2b083a4d832c7875c63a261c6b10c62898bf428351ea7d8d05136a46f9498cdb78c51a0223ca988cbc3481041b997dc5d6a9f16f02ec91 SHA512 844850db93b8c4dab19dd364e674ee3d61b2fcb8e020ab3d314f240065ee17aeceea21e9ddc438a7d09d56410e3f82147a57425f76bb01e26d82872934269477
diff --git a/dev-cpp/pangomm/pangomm-2.50.0.ebuild b/dev-cpp/pangomm/pangomm-2.50.0.ebuild
new file mode 100644
index 000000000000..ff1f9a59e9ed
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.50.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.16.0:1.16[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.68.0:2.68[doc?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-3:3[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.49.4[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc build-documentation)
+ )
+ meson_src_configure
+}