summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-21 18:52:46 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-21 19:17:26 -0700
commita05ac87cccc577ff5facb4fdff286c4488c7ec66 (patch)
tree7ea53385395562994d78146c53032ab431c46083 /dev-cpp
parentdev-cpp/atkmm: Version bump to 2.36.1 (diff)
downloadgentoo-a05ac87cccc577ff5facb4fdff286c4488c7ec66.tar.gz
gentoo-a05ac87cccc577ff5facb4fdff286c4488c7ec66.tar.bz2
gentoo-a05ac87cccc577ff5facb4fdff286c4488c7ec66.zip
dev-cpp/cairomm: Version bump to 1.14.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cairomm/Manifest1
-rw-r--r--dev-cpp/cairomm/cairomm-1.14.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/Manifest b/dev-cpp/cairomm/Manifest
index cfd46c2e66c8..9dcac893621b 100644
--- a/dev-cpp/cairomm/Manifest
+++ b/dev-cpp/cairomm/Manifest
@@ -1,2 +1,3 @@
DIST cairomm-1.14.2.tar.xz 603804 BLAKE2B 37417fc13f3213c1cd51ac2b0f17e0624c0592f6115a66c96295b6fa2f9974bee7c138f5087b130211a6e4f9fba045404d85e9aa08a36d9000415132400d4da8 SHA512 aef374fca25ad22770407e36512046b266d71ebeccd47fb629cfbf2f67783aa314bb335b972088a88d98417a4774d6f144cd2769c452f8aa23770eae08dca592
+DIST cairomm-1.14.3.tar.xz 604572 BLAKE2B a626ee20a229c4597622e7ead3320e5ff971632548488e970b877712d5579731093a14791a13416bec783e180a4f8432be1a743c7a5d77af2fdf30fa36ee3caa SHA512 8dc8a0de733904742c54d4935b596d4103f2e498c6735894bc6a5a81eb4962c6ea944bad94102b18b25850f78e948d38f117c566b197bc76da23a4e88b62ee4e
DIST cairomm-1.16.0.tar.xz 579604 BLAKE2B 3aaac8039d13f13ef8fb844e38cb0cd9b0565559544c7a4cab544a46f8f8bdb6d4ee1b8318ec5d9991c33264cd3335a8796e6a49553735516a184565875e1d08 SHA512 51929620feeac45377da5d486ea7a091bbd10ad8376fb16525328947b9e6ee740cdc8e8bd190a247b457cc9fec685a829c81de29b26cabaf95383ef04cce80d3
diff --git a/dev-cpp/cairomm/cairomm-1.14.3.ebuild b/dev-cpp/cairomm/cairomm-1.14.3.ebuild
new file mode 100644
index 000000000000..79302671e416
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.14.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="https://cairographics.org/cairomm/"
+SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libsigc++-2.6.0:2[doc?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.0[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-documentation=$(multilib_native_usex doc true false)
+ -Dbuild-examples=false
+ -Dbuild-tests=$(usex test true false)
+ -Dboost-shared=true
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ meson_src_test
+}