summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Henke <Jan.Henke@taujhe.de>2017-12-03 22:48:16 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-03 23:50:41 +0100
commita344988b3992f7703680aba89b3cf7332f88a443 (patch)
treec0acb7c302284915482c36791e621ab3f21c6620 /dev-cpp
parentnet-dns/pdns-recursor: Cleanup (diff)
downloadgentoo-a344988b3992f7703680aba89b3cf7332f88a443.tar.gz
gentoo-a344988b3992f7703680aba89b3cf7332f88a443.tar.bz2
gentoo-a344988b3992f7703680aba89b3cf7332f88a443.zip
dev-cpp/gsl: use system catch for USE="test".
Closes: https://bugs.gentoo.org/636828 Closes: https://github.com/gentoo/gentoo/pull/6431 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gsl/Manifest2
-rw-r--r--dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch31
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-cpp/gsl/Manifest b/dev-cpp/gsl/Manifest
index 3b53acf9b7e3..eb36ecd5112e 100644
--- a/dev-cpp/gsl/Manifest
+++ b/dev-cpp/gsl/Manifest
@@ -1 +1 @@
-DIST gsl-0_pre20171105.tar.gz 55870 SHA256 5adc4b4ba53102099f63b898da161469a854d4fd47e90195421fbe8bd8b50352 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a WHIRLPOOL 98e26057646f6be4cc6632901b2b45c5e46218e9048cd64561f7f118ee0e8feadeca3ca66a0b73a36a431b666fe7946c6f864dbcf97296bae3945b2350dcf2e5
+DIST gsl-0_pre20171105.tar.gz 55870 BLAKE2B cc26a8a304a65cd6a487d22369b5b23169e07144a7629388fffdbf263619c0849f00efcc1a072408e3e89dd933e3309c15049d0fec30de07267b5b693c5c9657 SHA512 0db9cae9af710c45f66d1e2b73e2002f921876d400165d13dbe9ede7aa9335249458a9f97d4eda4cff0b3a5ceebb6ef84b631310921011fedee8776fcec89e6a
diff --git a/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch b/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch
new file mode 100644
index 000000000000..e72eae02311e
--- /dev/null
+++ b/dev-cpp/gsl/files/gsl-0_pre20171105-use_system_catch-636828.patch
@@ -0,0 +1,31 @@
+# Disable upstreams catch download, we always want to use the system installed
+# version. Gentoo bug 636828.
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 86ce5a4..9b7d4f7 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -10,21 +10,8 @@ list(APPEND CATCH_CMAKE_ARGS
+ "-DNO_SELFTEST=true"
+ )
+
+-if(GIT_FOUND)
+- # add catch
+- ExternalProject_Add(
+- catch
+- PREFIX ${CMAKE_BINARY_DIR}/catch
+- GIT_REPOSITORY https://github.com/catchorg/Catch2.git
+- GIT_TAG v2.0.1
+- CMAKE_ARGS ${CATCH_CMAKE_ARGS}
+- LOG_DOWNLOAD 1
+- UPDATE_DISCONNECTED 1
+- )
+-else()
+- # assume catch is installed in a system directory
+- add_custom_target(catch)
+-endif()
++# assume catch is installed in a system directory
++add_custom_target(catch)
+
+ # this interface adds compile options to how the tests are run
+ # please try to keep entries ordered =)