summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-27 01:27:41 +0000
committerSam James <sam@gentoo.org>2021-03-27 02:57:36 +0000
commitad7f93d52342c57be176764b89aed9ae401c7f8a (patch)
treee5c7c94c856bdb1c1d358d0a7b4282f8b8377ecc /dev-cpp
parentdev-cpp/libmcpp: fix build with slibtool (diff)
downloadgentoo-ad7f93d52342c57be176764b89aed9ae401c7f8a.tar.gz
gentoo-ad7f93d52342c57be176764b89aed9ae401c7f8a.tar.bz2
gentoo-ad7f93d52342c57be176764b89aed9ae401c7f8a.zip
dev-cpp/libmcpp: (security) bump to 2.7.2_p5 (Debian)
Easier to just use the Debian patchset here. Bug: https://bugs.gentoo.org/718808 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libmcpp/Manifest1
-rw-r--r--dev-cpp/libmcpp/libmcpp-2.7.2_p5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/libmcpp/Manifest b/dev-cpp/libmcpp/Manifest
index c70198b721eb..cc1df396280a 100644
--- a/dev-cpp/libmcpp/Manifest
+++ b/dev-cpp/libmcpp/Manifest
@@ -1 +1,2 @@
DIST mcpp-2.7.2.tar.gz 1533457 BLAKE2B 4368fd1c667923ab3b60ce79f8421c549a9d9105957ca87b9ba49be513cb1be7f220a3ddbaf306e860014d5211af480d07170d912d3d4a80345d8eab45fd6c00 SHA512 1ca885cb13fdb684de9d0595a9215b52f48a93a69077d82cdcacafe40d9a61fb77b00a3ff2b8890e7bc0a0fcc0c8d70d4093c00c280351cd4459aba67c573235
+DIST mcpp_2.7.2-5.debian.tar.xz 7528 BLAKE2B 92f455809cfb49d97ca4e62c7087ebe2ebe0ce835e8f12d6e93b1df2ec1e15472f242637f320be2b6bada85b193545fcf3608e8c9a935805a5f052909d3c6f0b SHA512 08509945048ccc4525ecd61d3f901a4d81fe73c1db84c26b76664d5127970af45662a168b99836b58467afc7202a1a20e0dfe8954a87e4cd1368f2136d7955be
diff --git a/dev-cpp/libmcpp/libmcpp-2.7.2_p5.ebuild b/dev-cpp/libmcpp/libmcpp-2.7.2_p5.ebuild
new file mode 100644
index 000000000000..bc6a9a1d2336
--- /dev/null
+++ b/dev-cpp/libmcpp/libmcpp-2.7.2_p5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN=${PN/lib/}
+MY_P=$(ver_cut 1-4 ${MY_PN}-${PV})
+
+DESCRIPTION="A portable C++ preprocessor"
+HOMEPAGE="http://mcpp.sourceforge.net"
+SRC_URI="mirror://sourceforge/mcpp/${MY_P}.tar.gz"
+SRC_URI+=" https://deb.debian.org/debian/pool/main/m/${MY_PN}/${MY_PN}_${PV/_p/-}.debian.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86 ~x86-linux ~x64-macos"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.2-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #718808
+ eapply "${WORKDIR}"/debian/patches/*.patch
+
+ # bug #778461
+ sed -i 's/-lmcpp/libmcpp.la/' src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-mcpplib \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}