summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2021-05-17 11:03:08 +0200
committerSam James <sam@gentoo.org>2021-06-10 00:19:17 +0000
commitb0aa532afd2954423184d67f407a1e866613b0f2 (patch)
treedaa1a10d9efc4c71563190889cbeac9ab04a9620 /dev-cpp
parentmedia-libs/oidn: New package (diff)
downloadgentoo-b0aa532afd2954423184d67f407a1e866613b0f2.tar.gz
gentoo-b0aa532afd2954423184d67f407a1e866613b0f2.tar.bz2
gentoo-b0aa532afd2954423184d67f407a1e866613b0f2.zip
dev-cpp/pystring: New package
Pystring is a collection of C++ functions which match the interface and behavior of python's string class methods using std::string. Implemented in C++, it does not require or make use of a python interpreter. It provides convenience and familiarity for common string operations not included in the standard C++ library. It's also useful in environments where both C++ and python are used. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pystring/Manifest1
-rw-r--r--dev-cpp/pystring/metadata.xml15
-rw-r--r--dev-cpp/pystring/pystring-1.1.3.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-cpp/pystring/Manifest b/dev-cpp/pystring/Manifest
new file mode 100644
index 000000000000..eb3773a17b36
--- /dev/null
+++ b/dev-cpp/pystring/Manifest
@@ -0,0 +1 @@
+DIST pystring-1.1.3.tar.gz 18364 BLAKE2B caab1a3b1dc688ad6ecbb32e5e8139bb883a88b78ce8a021229924d57376e94b17d89277e2fccf4f7ec478c81ee9259c5e56848f4388c44b2eab9cfb841bcfb8 SHA512 a46bb2e96d6eb351a4a8097cde46ac2877d28e88f9e57e0ac36c42e8fc8543517c4be70306a01e2f88a891fc53c612494aeb37f47a200d94b8e1b050ed16eff6
diff --git a/dev-cpp/pystring/metadata.xml b/dev-cpp/pystring/metadata.xml
new file mode 100644
index 000000000000..1ce859e3e5b3
--- /dev/null
+++ b/dev-cpp/pystring/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darkdefende@gmail.com</email>
+ <name>Sebastian Parborg</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">imageworks/pystring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/pystring/pystring-1.1.3.ebuild b/dev-cpp/pystring/pystring-1.1.3.ebuild
new file mode 100644
index 000000000000..78410abecfd4
--- /dev/null
+++ b/dev-cpp/pystring/pystring-1.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ functions matching the interface and behavior of python string methods"
+HOMEPAGE="https://github.com/imageworks/pystring"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imageworks/pystring.git"
+else
+ SRC_URI="https://github.com/imageworks/pystring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/libc
+ sys-devel/libtool
+"
+RESTRICT="mirror"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+
+src_compile() {
+ sed -i -e "s|-O3|${CXXFLAGS}|g" Makefile || die
+ emake LIBDIR="${S}" install
+
+ # Fix header location
+ mkdir ${S}/pystring || die
+ mv ${S}/pystring.h ${S}/pystring || die
+}
+
+src_install() {
+ dolib.so ${S}/libpystring.so{,.0{,.0.0}}
+ doheader -r ${S}/pystring
+}