summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-09-25 08:46:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 16:00:46 +0200
commitf31f3ca73aa13f79a6a5bf2f71d93aa693010616 (patch)
treeea6aef826c6212f6bc1ae4f9c4ed331b6e0765e1 /dev-cpp
parentsci-astronomy/stellarium: drop 0.21.3, 0.22.1, 0.22.1-r1 (diff)
downloadgentoo-f31f3ca73aa13f79a6a5bf2f71d93aa693010616.tar.gz
gentoo-f31f3ca73aa13f79a6a5bf2f71d93aa693010616.tar.bz2
gentoo-f31f3ca73aa13f79a6a5bf2f71d93aa693010616.zip
dev-cpp/asio: drop 1.22.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/27433 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.22.1.ebuild63
-rw-r--r--dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch29
3 files changed, 0 insertions, 93 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index e0e78768d961..fb0187b3051b 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,2 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
-DIST asio-1.22.1.tar.bz2 3085878 BLAKE2B 07326a2273d5b8c0aef8402c92a6a88abbcb961d2a029596d58735d6626279e6d4d591371cc368a41fac1d0161b8786174ba71153e73aac38fa81a83f5f5be86 SHA512 be4a066d9f73662f68a771f63a59fc2e16e8ee1ae1ca6c581e09922514029e58c479edfc0517ee6b29a1fd377d202a2a6eb80d9d17f6e957233c11331f04a479
DIST asio-1.22.2.tar.bz2 3077065 BLAKE2B b3660cf3c72d2d7ae122f89e8afb967cb89cc1de3f4859d481bbb8250cad6f03f187a4deb9e500a6231abdc5c9e727ef910c59d7c8b75bc6ba0f12ef94f05252 SHA512 93ea423cec8d13e525bf654291b6edd685f079c2af2da5a6f44dfe0b913e0f3df0a4770f1240ff760bae7842eee8ee3a13bed621c2ee1499abc76b100ebe3885
diff --git a/dev-cpp/asio/asio-1.22.1.ebuild b/dev-cpp/asio/asio-1.22.1.ebuild
deleted file mode 100644
index f100d6fc13a9..000000000000
--- a/dev-cpp/asio/asio-1.22.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Asynchronous Network Library"
-HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/boost
- dev-libs/openssl
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-cpp20ex.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- if ! use test; then
- # Don't build nor install any examples or unittests
- # since we don't have a script to run them
- cat > src/Makefile.in <<-EOF || die
- all:
-
- install:
-
- clean:
- EOF
- fi
-}
-
-src_install() {
- use doc && local HTML_DOCS=( doc/. )
- default
-
- if use examples; then
- # Get rid of the object files
- emake clean
- dodoc -r src/examples
- docompress -x /usr/share/doc/${PF}/examples
-
- # Make links to the example .cpp files work
- # https://bugs.gentoo.org/828648
- if use doc; then
- dosym ../examples /usr/share/doc/${PF}/src/examples
- fi
- fi
-}
diff --git a/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch b/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch
deleted file mode 100644
index 55de22b8a136..000000000000
--- a/dev-cpp/asio/files/asio-1.22.1-cpp20ex.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-The cpp20 dir doesn't exist
-https://github.com/chriskohlhoff/asio/issues/1026
-
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -15,7 +15,6 @@ EXAMPLES_CPP17 = examples/cpp17
- endif
-
- if HAVE_CXX20
--EXAMPLES_CPP20 = examples/cpp20
- endif
-
- SUBDIRS = \
-@@ -23,7 +22,6 @@ SUBDIRS = \
- $(EXAMPLES_CPP11) \
- $(EXAMPLES_CPP14) \
- $(EXAMPLES_CPP17) \
-- $(EXAMPLES_CPP20) \
- tests
-
- DIST_SUBDIRS = examples/cpp03 examples/cpp11 examples/cpp14 examples/cpp17 tests
---- a/configure.ac
-+++ b/configure.ac
-@@ -241,4 +241,4 @@ AC_OUTPUT([
- src/examples/cpp11/Makefile
- src/examples/cpp14/Makefile
- src/examples/cpp17/Makefile
-- src/examples/cpp20/Makefile])
-+ ])