summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-06-01 22:54:20 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-06-01 22:55:09 +0100
commitf7b7c15da117ceb50850679f14573de8a1e22e4e (patch)
tree8d97cf351ef019d05789de4e9e9011e5d3f5d35a /dev-cpp
parentdev-python/jwcrypto: Bump to 0.9.0 (diff)
downloadgentoo-f7b7c15da117ceb50850679f14573de8a1e22e4e.tar.gz
gentoo-f7b7c15da117ceb50850679f14573de8a1e22e4e.tar.bz2
gentoo-f7b7c15da117ceb50850679f14573de8a1e22e4e.zip
dev-cpp/htmlcxx: Patch to fix building with GCC 11 / C++-17
Closes: https://bugs.gentoo.org/786684 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch26
-rw-r--r--dev-cpp/htmlcxx/htmlcxx-0.87.ebuild6
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch b/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch
new file mode 100644
index 000000000000..9f8f060de456
--- /dev/null
+++ b/dev-cpp/htmlcxx/files/htmlcxx-0.87-c++17.patch
@@ -0,0 +1,26 @@
+https://sourceforge.net/p/htmlcxx/patches/8/
+
+diff --color -Naur a/html/CharsetConverter.cc b/html/CharsetConverter.cc
+--- a/html/CharsetConverter.cc 2018-12-29 03:13:56.000000000 +0000
++++ b/html/CharsetConverter.cc 2021-05-31 23:03:10.705334580 +0100
+@@ -7,7 +7,7 @@
+ using namespace std;
+ using namespace htmlcxx;
+
+-CharsetConverter::CharsetConverter(const string &from, const string &to) throw (Exception)
++CharsetConverter::CharsetConverter(const string &from, const string &to)
+ {
+ mIconvDescriptor = iconv_open(to.c_str(), from.c_str());
+ if (mIconvDescriptor == (iconv_t)(-1))
+diff --color -Naur a/html/CharsetConverter.h b/html/CharsetConverter.h
+--- a/html/CharsetConverter.h 2018-12-29 03:13:56.000000000 +0000
++++ b/html/CharsetConverter.h 2021-05-31 23:03:19.042574598 +0100
+@@ -17,7 +17,7 @@
+ : std::runtime_error(arg) {}
+ };
+
+- CharsetConverter(const std::string &from, const std::string &to) throw (Exception);
++ CharsetConverter(const std::string &from, const std::string &to);
+ ~CharsetConverter();
+
+ std::string convert(const std::string &input);
diff --git a/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
index fdcb01bc5cf2..3ac9069308c3 100644
--- a/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
+++ b/dev-cpp/htmlcxx/htmlcxx-0.87.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,6 +13,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
+PATCHES=(
+ "${FILESDIR}"/${P}-c++17.patch
+)
+
ECONF_SOURCE="${S}"
multilib_src_configure() {