summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-27 18:45:19 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-03 18:14:05 -0700
commitf998f8f3ef8df5641c693424367b39e821ce278e (patch)
tree6901d8d158103acaec4412bed3ee457ab69c08ab /dev-cpp
parentdev-cpp/glibmm: Switch to meson-multilib (diff)
downloadgentoo-f998f8f3ef8df5641c693424367b39e821ce278e.tar.gz
gentoo-f998f8f3ef8df5641c693424367b39e821ce278e.tar.bz2
gentoo-f998f8f3ef8df5641c693424367b39e821ce278e.zip
dev-cpp/gtkmm: Switch to meson-multilib
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtkmm/gtkmm-3.24.5.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-3.24.5.ebuild b/dev-cpp/gtkmm/gtkmm-3.24.5.ebuild
index d1922c85351e..0296e9dcf52c 100644
--- a/dev-cpp/gtkmm/gtkmm-3.24.5.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-3.24.5.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org meson multilib-minimal python-any-r1 virtualx
+inherit gnome.org meson-multilib python-any-r1 virtualx
DESCRIPTION="C++ interface for GTK+"
HOMEPAGE="https://www.gtkmm.org"
@@ -42,21 +42,13 @@ multilib_src_configure() {
local emesonargs=(
-Dbuild-atkmm-api=true
-Dbuild-demos=false
- -Dbuild-documentation=$(multilib_native_usex doc true false)
- -Dbuild-tests=$(usex test true false)
- -Dbuild-x11-api=$(usex X true false)
+ $(meson_native_use_bool doc build-documentation)
+ $(meson_use test build-tests)
+ $(meson_use X build-x11-api)
)
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
multilib_src_test() {
virtx meson_src_test
}