summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 09:17:17 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:20:48 +0200
commit4460de5791fb8ff96d35d4596a96c79fb9239a98 (patch)
treeb0ab102a7abc80f790699b32282a0cb1b3625833 /dev-db/hyperdex
parentapp-vim/pydiction: [QA] Add missing python metadata variables (diff)
downloadgentoo-4460de5791fb8ff96d35d4596a96c79fb9239a98.tar.gz
gentoo-4460de5791fb8ff96d35d4596a96c79fb9239a98.tar.bz2
gentoo-4460de5791fb8ff96d35d4596a96c79fb9239a98.zip
dev-db/hyperdex: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-db/hyperdex')
-rw-r--r--dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild23
-rw-r--r--dev-db/hyperdex/hyperdex-1.7.1.ebuild23
-rw-r--r--dev-db/hyperdex/hyperdex-1.8.0.ebuild23
-rw-r--r--dev-db/hyperdex/hyperdex-1.8.1.ebuild23
-rw-r--r--dev-db/hyperdex/hyperdex-9999.ebuild18
5 files changed, 74 insertions, 36 deletions
diff --git a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
index 882ead1f3e2c..785eef7c7353 100644
--- a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-# Tests fail, again
-RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
-PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -19,8 +18,13 @@ KEYWORDS="~amd64"
IUSE="test +python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests fail, still
+RESTRICT="test"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
@@ -30,17 +34,20 @@ DEPEND="dev-cpp/glog
dev-libs/replicant
dev-libs/libmacaroons
dev-libs/libtreadstone
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( python )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
- use python && python-single-r1_pkg_setup
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
diff --git a/dev-db/hyperdex/hyperdex-1.7.1.ebuild b/dev-db/hyperdex/hyperdex-1.7.1.ebuild
index 882ead1f3e2c..785eef7c7353 100644
--- a/dev-db/hyperdex/hyperdex-1.7.1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.7.1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-# Tests fail, again
-RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
-PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -19,8 +18,13 @@ KEYWORDS="~amd64"
IUSE="test +python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests fail, still
+RESTRICT="test"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
@@ -30,17 +34,20 @@ DEPEND="dev-cpp/glog
dev-libs/replicant
dev-libs/libmacaroons
dev-libs/libtreadstone
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( python )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
- use python && python-single-r1_pkg_setup
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
diff --git a/dev-db/hyperdex/hyperdex-1.8.0.ebuild b/dev-db/hyperdex/hyperdex-1.8.0.ebuild
index fea87820e0e6..6d245f6659b3 100644
--- a/dev-db/hyperdex/hyperdex-1.8.0.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.8.0.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-# Tests fail, still
-RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
-PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -19,8 +18,13 @@ KEYWORDS="~amd64"
IUSE="test +python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests fail, still
+RESTRICT="test"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
>=dev-libs/hyperleveldb-1.2
@@ -31,17 +35,20 @@ DEPEND="dev-cpp/glog
>=dev-libs/replicant-0.8
>=dev-libs/libmacaroons-0.3
>=dev-libs/libtreadstone-0.2
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( python )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
- use python && python-single-r1_pkg_setup
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
diff --git a/dev-db/hyperdex/hyperdex-1.8.1.ebuild b/dev-db/hyperdex/hyperdex-1.8.1.ebuild
index fea87820e0e6..6d245f6659b3 100644
--- a/dev-db/hyperdex/hyperdex-1.8.1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.8.1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-# Tests fail, still
-RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
-PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -19,8 +18,13 @@ KEYWORDS="~amd64"
IUSE="test +python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests fail, still
+RESTRICT="test"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
>=dev-libs/hyperleveldb-1.2
@@ -31,17 +35,20 @@ DEPEND="dev-cpp/glog
>=dev-libs/replicant-0.8
>=dev-libs/libmacaroons-0.3
>=dev-libs/libtreadstone-0.2
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( python )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
- use python && python-single-r1_pkg_setup
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)
diff --git a/dev-db/hyperdex/hyperdex-9999.ebuild b/dev-db/hyperdex/hyperdex-9999.ebuild
index 0f20e45c61f4..92491ebb675a 100644
--- a/dev-db/hyperdex/hyperdex-9999.ebuild
+++ b/dev-db/hyperdex/hyperdex-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-PYTHON_COMPAT=( python2_7)
+PYTHON_COMPAT=( python2_7 )
+
inherit eutils python-r1 autotools git-r3
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -18,8 +20,10 @@ SRC_URI="http://dev.gentooexperimental.org/~patrick/autotools-java.tar"
IUSE="+python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
@@ -27,15 +31,21 @@ DEPEND="dev-cpp/glog
dev-libs/busybee
dev-libs/popt
dev-libs/replicant
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_prepare() {
cd m4; tar xf "${DISTDIR}/autotools-java.tar"
cd ..
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)