summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/lib_mysqludf_fPROJ4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/lib_mysqludf_fPROJ4')
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/Manifest1
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch35
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild64
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/metadata.xml7
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_fPROJ4/Manifest b/dev-db/lib_mysqludf_fPROJ4/Manifest
new file mode 100644
index 000000000000..e824128c52e5
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/Manifest
@@ -0,0 +1 @@
+DIST lib_mysqludf_fPROJ4-0.1.0.tar.gz 2573 SHA256 22ec139f1652040828da18a4b3a469355486d459f8000d25381422b9c9e45cdd SHA512 cc0307bcbdf15a37f77fced46b262783327fbd1e9883bd2d3f55c005bc5948ea7d2b7afa98a75390045636abbb04bb22aeaafdbe670e5642710a6a4a785fd3b3 WHIRLPOOL 8294e54ccae4028796db1efa58a2c9a83625df11a158382ea096aa713d79cda1dbab993926d3b00604e5edca80c27771ba11f5e9b3da719fea69c63cabb1b493
diff --git a/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch b/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
new file mode 100644
index 000000000000..0b9669991cb3
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
@@ -0,0 +1,35 @@
+--- lib_mysqludf_fPROJ4.c.orig 2010-05-09 13:46:12.000000000 +0200
++++ lib_mysqludf_fPROJ4.c 2011-10-19 02:32:48.000000000 +0200
+@@ -1,5 +1,3 @@
+-/*
+-
+ /*
+ lib_mysqludf_fPROJ4 - An extended set of scientific functions which
+ converts geographic longitude and latitude coordinates into cartesian
+@@ -178,7 +176,7 @@
+ }
+ double fPROJ4_transform(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y,z;
+ int p,t;
+
+@@ -248,7 +246,7 @@
+ }
+ double fPROJ4_Geo2UTM(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y;
+ int p,t,zone;
+ char *tmp;
+@@ -323,7 +321,7 @@
+ }
+ double fPROJ4_UTM2Geo(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y;
+ int p,t,zone;
+ char *tmp;
diff --git a/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild b/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
new file mode 100644
index 000000000000..f7d8d6e6e98a
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MySQL UDFs which converts geographic/cartesian coordinates"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_fPROJ4/"
+SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ sci-libs/proj"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-warnings.patch"
+
+ # fix doc (BOM, CR/LF, soname)
+ sed -i -e '1 s|^\xEF\xBB\xBF||' \
+ -e "s|'\(${PN}\).*'|'\1.so'|g" ${PN}.sql
+ echo >> ${PN}.sql # add LF
+ edos2unix ${PN}.sql
+}
+
+src_compile() {
+ _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} -lproj \
+ -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
+}
+
+src_install() {
+ exeinto "${MYSQL_PLUGINDIR}"
+ doexe ${PN}.so
+ dodoc ${PN}.sql
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_fPROJ4/metadata.xml b/dev-db/lib_mysqludf_fPROJ4/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>