summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/libdbi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/libdbi')
-rw-r--r--dev-db/libdbi/Manifest1
-rw-r--r--dev-db/libdbi/files/dbi.pc.in10
-rw-r--r--dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch22
-rw-r--r--dev-db/libdbi/libdbi-0.9.0.ebuild59
-rw-r--r--dev-db/libdbi/metadata.xml10
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-db/libdbi/Manifest b/dev-db/libdbi/Manifest
new file mode 100644
index 000000000000..bc30e36d9b42
--- /dev/null
+++ b/dev-db/libdbi/Manifest
@@ -0,0 +1 @@
+DIST libdbi-0.9.0.tar.gz 1194284 SHA256 dafb6cdca524c628df832b6dd0bf8fabceb103248edb21762c02d3068fca4503 SHA512 ee8777195af43057409d051a6055ec0467cd926d48da076458b09f91d2f0995a1cc4bc071762e401b7bdcd8a4173fd8ea3472db3a1518e34b4c5b5ed24e4e2ce WHIRLPOOL 32770a9247670f30cd280a7c2111239d251e09d7c72e6b3890d02fdf3db7384de88e899431999e1b476ac099d4b8cd9f4d727d9610d47d62dccb9229bcdb36b7
diff --git a/dev-db/libdbi/files/dbi.pc.in b/dev-db/libdbi/files/dbi.pc.in
new file mode 100644
index 000000000000..a0144549db9b
--- /dev/null
+++ b/dev-db/libdbi/files/dbi.pc.in
@@ -0,0 +1,10 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@/dbi
+
+Name: libdbi
+Description: database-independent abstraction layer in C
+Version: @VERSION@
+Libs: -L${libdir} -ldbi
+Cflags: -I${includedir} -I${includedir}/dbi
diff --git a/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch b/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch
new file mode 100644
index 000000000000..c0818b9c295b
--- /dev/null
+++ b/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch
@@ -0,0 +1,22 @@
+diff -Nuar libdbi-0.9.0.orig/configure.in libdbi-0.9.0/configure.in
+--- libdbi-0.9.0.orig/configure.in 2013-08-29 15:34:54.883102666 +0000
++++ libdbi-0.9.0/configure.in 2013-08-29 15:36:07.827905613 +0000
+@@ -201,14 +201,13 @@
+ dnl See whether to build the docs
+ dnl ==============================
+
+-ac_docs="YES"
++ac_docs="yes"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ if test "$enable_docs" = "no"; then
+- ac_docs="NO"
+- fi])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ docs_subdirs="doc"
+ else
+ docs_subdirs=""
diff --git a/dev-db/libdbi/libdbi-0.9.0.ebuild b/dev-db/libdbi/libdbi-0.9.0.ebuild
new file mode 100644
index 000000000000..f4a26ba90390
--- /dev/null
+++ b/dev-db/libdbi/libdbi-0.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools multilib
+
+DESCRIPTION="libdbi is a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://libdbi.sourceforge.net/"
+LICENSE="LGPL-2.1"
+
+IUSE="doc static-libs"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+SLOT=0
+
+DOCS="AUTHORS ChangeLog README README.osx TODO"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/pkgconfig
+ doc? ( app-text/openjade )
+"
+PDEPEND=">=dev-db/libdbi-drivers-0.9.0" # On purpose, libdbi-drivers 0.8.4 does not exist
+
+src_unpack() {
+ unpack ${A}
+ chown -R portage:portage "${S}"
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}"/${PN}-0.9.0-fix-ac-macro.patch
+ #epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
+ #cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
+ epatch "${FILESDIR}"/libdbi-0.9.0-doc-build-fix.patch
+
+ # configure.in has been changed
+ eautoreconf
+ # should append CFLAGS, not replace them
+ sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ default
+
+ prune_libtool_files --all
+
+ # syslog-ng requires dbi.pc
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins dbi.pc
+}
diff --git a/dev-db/libdbi/metadata.xml b/dev-db/libdbi/metadata.xml
new file mode 100644
index 000000000000..f3e9046633f0
--- /dev/null
+++ b/dev-db/libdbi/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libdbi</remote-id>
+ </upstream>
+</pkgmetadata>