summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
committerUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
commit18c044e24a836c6d333c99b557bc8a6ee6be810e (patch)
tree2d6cea7f70e48ac1258215482c37d685ec940723 /dev-db/mongodb/mongodb-2.6.8.ebuild
parentdev-db/mongodb: version bump and copyright fix (diff)
downloadgentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.gz
gentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.bz2
gentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.zip
dev-db/mongodb: fix REPLACING_VERSION detection #589458
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-db/mongodb/mongodb-2.6.8.ebuild')
-rw-r--r--dev-db/mongodb/mongodb-2.6.8.ebuild46
1 files changed, 25 insertions, 21 deletions
diff --git a/dev-db/mongodb/mongodb-2.6.8.ebuild b/dev-db/mongodb/mongodb-2.6.8.ebuild
index 1fff19c51cdc..4059772252d0 100644
--- a/dev-db/mongodb/mongodb-2.6.8.ebuild
+++ b/dev-db/mongodb/mongodb-2.6.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -156,25 +156,29 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 2.6 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
- ewarn " "
- if use mms-agent; then
- ewarn "MMS Agent configuration file has been moved to :"
- ewarn " /etc/mms-agent.conf"
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.6 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/2.6-upgrade/"
+ ewarn " "
+ if use mms-agent; then
+ ewarn "MMS Agent configuration file has been moved to :"
+ ewarn " /etc/mms-agent.conf"
+ fi
+ break
+ else
+ if use mms-agent; then
+ elog "Edit your MMS Agent configuration file :"
+ elog " /etc/mms-agent.conf"
+ fi
fi
- else
- if use mms-agent; then
- elog "Edit your MMS Agent configuration file :"
- elog " /etc/mms-agent.conf"
- fi
- fi
+ done
}