summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
committerUltrabug <ultrabug@gentoo.org>2016-08-19 14:59:39 +0200
commit18c044e24a836c6d333c99b557bc8a6ee6be810e (patch)
tree2d6cea7f70e48ac1258215482c37d685ec940723 /dev-db/mongodb/mongodb-3.0.12.ebuild
parentdev-db/mongodb: version bump and copyright fix (diff)
downloadgentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.gz
gentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.tar.bz2
gentoo-18c044e24a836c6d333c99b557bc8a6ee6be810e.zip
dev-db/mongodb: fix REPLACING_VERSION detection #589458
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-db/mongodb/mongodb-3.0.12.ebuild')
-rw-r--r--dev-db/mongodb/mongodb-3.0.12.ebuild36
1 files changed, 20 insertions, 16 deletions
diff --git a/dev-db/mongodb/mongodb-3.0.12.ebuild b/dev-db/mongodb/mongodb-3.0.12.ebuild
index 4c1614ece5c1..437e0b06baa8 100644
--- a/dev-db/mongodb/mongodb-3.0.12.ebuild
+++ b/dev-db/mongodb/mongodb-3.0.12.ebuild
@@ -137,20 +137,24 @@ src_test() {
}
pkg_postinst() {
- if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
- ewarn "!! IMPORTANT !!"
- ewarn " "
- ewarn "${PN} configuration files have changed !"
- ewarn " "
- ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
- ewarn " "
- ewarn "Make sure you also follow the upgrading process :"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
- ewarn " "
- ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
- ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
- ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
- ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
- fi
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 3.0 ${v}; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "${PN} configuration files have changed !"
+ ewarn " "
+ ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
+ ewarn " "
+ ewarn "Make sure you also follow the upgrading process :"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
+ ewarn " "
+ ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
+ ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
+ ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
+ ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
+ break
+ fi
+ done
}