summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-02-04 20:25:19 +0000
committerThomas Deutschmann <whissi@gentoo.org>2021-02-04 23:25:08 +0100
commita0e3dd83cb226bf4ccd5b2b8dc847b8ecdb26f2b (patch)
treea01328bed0798d0eed13ca9234a43d97f8905748 /dev-db/mydumper
parentnet-analyzer/monitoring-plugins: drop old (diff)
downloadgentoo-a0e3dd83cb226bf4ccd5b2b8dc847b8ecdb26f2b.tar.gz
gentoo-a0e3dd83cb226bf4ccd5b2b8dc847b8ecdb26f2b.tar.bz2
gentoo-a0e3dd83cb226bf4ccd5b2b8dc847b8ecdb26f2b.zip
dev-db/mydumper: bump to 0.10.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mydumper')
-rw-r--r--dev-db/mydumper/Manifest1
-rw-r--r--dev-db/mydumper/mydumper-0.10.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/mydumper/Manifest b/dev-db/mydumper/Manifest
index 449f748f916e..a7f5c90330c6 100644
--- a/dev-db/mydumper/Manifest
+++ b/dev-db/mydumper/Manifest
@@ -1,2 +1,3 @@
+DIST mydumper-0.10.1.tar.gz 63967 BLAKE2B ad2876eb4fd6528c119d722e70b096d12698119e6d84737601d7bc0e71022926f579d21456b73b8ff1d384c961256538467badeaceaf60a92b333196a17dda10 SHA512 dbcb207c8ac61b286cd4464a3f2c67ea6972d1cab215c09a577cdf621f685011cc26e1e36399b72be2a8165b4e4c518b401be928b6a1a31e35d2f27c169dcc18
DIST mydumper-0.9.3.tar.gz 45320 BLAKE2B 6e6d4420ced29d4ea77aa257ee155ce0810fe7d0ac3bf22c22156dfcfba35a3c461e4115d5814b5e0050331151a5b0c3bd819c1ecc534b6644972bf76de5d004 SHA512 3bc2c85dbedf234aecca3b66f445e42bb7ddff83f914d5cc231f6a5755d1c2bf300ae9bf4bdea0717b45ea5338c6c336ec44f375dbf29570ed785ffddda53898
DIST mydumper-0.9.5.tar.gz 60010 BLAKE2B f74a949712526b3fc3b1957c9f9dc5c5f820d88f781926331e751eb99e6315b37bd8f38ac8a0e1943485cc74fe9b14a7e74e955c77ceba6b10bb1e18a7720d75 SHA512 5b72234c88fd22c103afb9fa5a7c3c99d6585cb450b8cc7385cfd23ae2ce09c0848d15767a5957a7b8f87a7614bdb058dea8990f1a2a12300c2c74fc9da2de75
diff --git a/dev-db/mydumper/mydumper-0.10.1.ebuild b/dev-db/mydumper/mydumper-0.10.1.ebuild
new file mode 100644
index 000000000000..5ba7f676d458
--- /dev/null
+++ b/dev-db/mydumper/mydumper-0.10.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL"
+HOMEPAGE="https://github.com/maxbube/mydumper"
+SRC_URI="https://github.com/maxbube/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+COMMON_DEPEND="dev-db/mysql-connector-c:=
+ dev-libs/glib:=
+ dev-libs/libpcre:=
+ dev-libs/openssl:0=
+ sys-libs/zlib:="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )"
+RDEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-atomic.patch" #654314
+)
+
+src_prepare() {
+ # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
+ sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt || die
+
+ # fix doc install path
+ sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=("-DBUILD_DOCS=$(usex doc)")
+
+ cmake-utils_src_configure
+}