summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-07-24 16:03:56 -0400
committerBrian Evans <grknight@gentoo.org>2018-07-24 16:03:56 -0400
commit68b6374a9322202a98da1e031388ef95bf13787c (patch)
tree58cdb2afb106b761fb6769377c6ba4ed3296b74d /dev-db/mysql++
parentdev-db/mysql++: Revbump on 2.x series (diff)
downloadgentoo-68b6374a9322202a98da1e031388ef95bf13787c.tar.gz
gentoo-68b6374a9322202a98da1e031388ef95bf13787c.tar.bz2
gentoo-68b6374a9322202a98da1e031388ef95bf13787c.zip
dev-db/mysql++: Clean old
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/Manifest2
-rw-r--r--dev-db/mysql++/mysql++-2.3.2.ebuild55
-rw-r--r--dev-db/mysql++/mysql++-3.1.0.ebuild49
-rw-r--r--dev-db/mysql++/mysql++-3.2.2.ebuild36
4 files changed, 0 insertions, 142 deletions
diff --git a/dev-db/mysql++/Manifest b/dev-db/mysql++/Manifest
index 8c9d12900560..879287d01bff 100644
--- a/dev-db/mysql++/Manifest
+++ b/dev-db/mysql++/Manifest
@@ -1,5 +1,3 @@
DIST mysql++-2.3.2.tar.gz 1627115 BLAKE2B 058ed41485474e4283a7200aa57398e85162f697f017ccfde7974b85457bb827d17bfdd522ef46818d42a75751a0eeb6ade39ded73e0265ee6811eb2769df3ea SHA512 b546c8369550e541c1a0b1b0e301fdd298a771cb709ad6c6ea3450a8f8bbe7533989a82d1c19cd9bf9a261d7a1fc4c3760919d3d5e3e43b5d698b75b7abf07f7
-DIST mysql++-3.1.0.tar.gz 1944101 BLAKE2B dabfa6491c2535fa974c6ee679d5130853dff1fe8530fc6e0ce1cd2762447c2430f9ccbd45dbfd0c67dfee8019d0446cb04b440d1352813dc76962ca8fea5b80 SHA512 bb57bbf03c80edabff701132877f407ecfa1b76958d7655415c59ec939e80fbe250951a16c3d5ea6988dd2c778b623605cb65bf810501f392be2f6b6ad07ad90
DIST mysql++-3.2.1.tar.gz 2256735 BLAKE2B 8d5e713926a405fa9b93af690554595d8cc79cc25af216103df241f549fd93e7fa051ef5f1a27e7c67825408b8310886bedaeb69bd80b6ea6cf1c320a94cc9d2 SHA512 936021dcf8568d3ee0c935e5c552acc6fd2b57849d1cc60e68b45b690d798d7bfbc1dedc04e21417d1b4c27017b471e4f6cb70de7f1904949b9222090a777de9
-DIST mysql++-3.2.2.tar.gz 3257359 BLAKE2B 180ffaa4d5a198795386f46a6be3bc6f50ded373057b5c6fe618ae3d0976ced8288647bc1beac64fbd7c93aab5f2a79ced4ecc947101e3118b39aa0b40b1eb1a SHA512 eb4250394027f1baafa660711d8221c9eb3a70ff2a37331c58807a97a67b84f792290b24830e851b2421f6ccf2867e9f3597af3af41530256c44521a4c4a55b1
DIST mysql++-3.2.3.tar.gz 3241023 BLAKE2B 5faa5711c7ed7c64346013bd1ca6e7dc20e5b23d33983a719c892bbd1002f3986206df6cfef54316f11aa480f18dbc0a2cf6944f9572f3a7dca24cdb73099eb9 SHA512 b6b0a9856ede9e5e08be0f5ed1689b1256f8cf31c3afbb9c9e7f68d0734380e25909ef31cd04be6b253c86b2f881df10f3793a2d3e32042375dbbab4b0700d0a
diff --git a/dev-db/mysql++/mysql++-2.3.2.ebuild b/dev-db/mysql++/mysql++-2.3.2.ebuild
deleted file mode 100644
index 7167c329599b..000000000000
--- a/dev-db/mysql++/mysql++-2.3.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="C++ API interface to the MySQL database"
-HOMEPAGE="http://tangentsoft.net/mysql++/"
-SRC_URI="http://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
-IUSE=""
-
-RDEPEND=">=virtual/mysql-4.0"
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-3"
-
-src_prepare() {
-
- epatch "${FILESDIR}"/${P}-gcc-4.3.patch
-
- for i in "${S}"/lib/*.h ; do
- sed -i \
- -e '/#include </s,mysql.h,mysql/mysql.h,g' \
- -e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
- "${i}" || die "Failed to sed ${i} for fixing MySQL includes"
- done
-}
-
-src_configure() {
- local myconf
- # we want C++ exceptions turned on
- myconf="--enable-exceptions"
- # give threads a try
- myconf="${myconf} --enable-thread-check"
- # not including the directives to where MySQL is because it seems to
- # find it just fine without
-
- # force the cflags into place otherwise they get totally ignored by
- # configure
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- econf ${myconf}
-}
-
-src_install() {
- default
- # install the docs and HTML pages
- dodoc README* CREDITS ChangeLog HACKERS Wishlist
- dohtml -r doc/html/*
- rm -r doc/html || die
- dodoc -r doc/*
-}
diff --git a/dev-db/mysql++/mysql++-3.1.0.ebuild b/dev-db/mysql++/mysql++-3.1.0.ebuild
deleted file mode 100644
index b945531b392b..000000000000
--- a/dev-db/mysql++/mysql++-3.1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="C++ API interface to the MySQL database"
-HOMEPAGE="http://tangentsoft.net/mysql++/"
-SRC_URI="http://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0/3"
-KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-RDEPEND=">=virtual/mysql-4.0"
-DEPEND="${RDEPEND}
- || ( >=sys-devel/gcc-3 >=sys-devel/gcc-apple-4 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0-gcc-as-needed.patch
- epatch "${FILESDIR}"/${PN}-3.2.1-gold.patch
-
- for i in "${S}"/lib/*.h ; do
- sed -i \
- -e '/#include </s,mysql.h,mysql/mysql.h,g' \
- -e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
- "${i}"
- done
- epatch_user
-}
-
-src_configure() {
- local myconf
- use prefix || local EPREFIX=
- myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
-
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- # install the docs and HTML pages
- dodoc README* CREDITS* ChangeLog HACKERS.txt Wishlist doc/ssqls-pretty
- dodoc -r doc/pdf/ doc/refman/ doc/userman/
- dohtml -r doc/html/
-}
diff --git a/dev-db/mysql++/mysql++-3.2.2.ebuild b/dev-db/mysql++/mysql++-3.2.2.ebuild
deleted file mode 100644
index a7f6809512a8..000000000000
--- a/dev-db/mysql++/mysql++-3.2.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="C++ API interface to the MySQL database"
-HOMEPAGE="http://tangentsoft.net/mysql++/"
-SRC_URI="http://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-RDEPEND="virtual/libmysqlclient:="
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.2.1-gold.patch"
- epatch_user
-}
-
-src_configure() {
- local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
- econf ${myconf}
-}
-
-src_install() {
- default
- # install the docs and HTML pages
- dodoc CREDITS* HACKERS.txt Wishlist doc/ssqls-pretty
- dodoc -r doc/pdf/ doc/refman/ doc/userman/
- dohtml -r doc/html/
-}