summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-07-26 08:40:51 -0400
committerBrian Evans <grknight@gentoo.org>2019-07-26 08:40:51 -0400
commit57f61a80872e0ceb8e89d2a2472e03e65a8f0320 (patch)
tree41646a6e04828a3b5967333b308d5bfa494ee10f /dev-db/mysql-init-scripts
parentsys-kernel/gentoo-sources: Linux patch 5.2.3 (diff)
downloadgentoo-57f61a80872e0ceb8e89d2a2472e03e65a8f0320.tar.gz
gentoo-57f61a80872e0ceb8e89d2a2472e03e65a8f0320.tar.bz2
gentoo-57f61a80872e0ceb8e89d2a2472e03e65a8f0320.zip
dev-db/mysql-init-scripts: Revbump to fix supervise-daemon syntax change
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-db/mysql-init-scripts')
-rw-r--r--dev-db/mysql-init-scripts/files/init.d-supervise-2.34
-rw-r--r--dev-db/mysql-init-scripts/mysql-init-scripts-2.3-r1.ebuild67
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-db/mysql-init-scripts/files/init.d-supervise-2.3 b/dev-db/mysql-init-scripts/files/init.d-supervise-2.3
index e611995b9a04..d0cbb312ccac 100644
--- a/dev-db/mysql-init-scripts/files/init.d-supervise-2.3
+++ b/dev-db/mysql-init-scripts/files/init.d-supervise-2.3
@@ -121,7 +121,7 @@ start() {
# local startup_early_timeout=${STARTUP_EARLY_TIMEOUT:-1000}
local tmpnice="${NICE:+"--nicelevel "}${NICE}"
local tmpionice="${IONICE:+"--ionice "}${IONICE}"
- supervise-daemon \
+ supervise-daemon "${SVCNAME}" \
${DEBUG:+"--verbose"} \
--pidfile "/run/${SVCNAME}.pid" \
${tmpnice} \
@@ -146,7 +146,7 @@ stop() {
ebegin "Stopping $(mysql_svcname)"
- supervise-daemon \
+ supervise-daemon "${SVCNAME}" \
${DEBUG:+"--verbose"} \
--stop \
--pidfile "/run/${SVCNAME}.pid"
diff --git a/dev-db/mysql-init-scripts/mysql-init-scripts-2.3-r1.ebuild b/dev-db/mysql-init-scripts/mysql-init-scripts-2.3-r1.ebuild
new file mode 100644
index 000000000000..b3283cf3ba24
--- /dev/null
+++ b/dev-db/mysql-init-scripts/mysql-init-scripts-2.3-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd s6 tmpfiles
+
+DESCRIPTION="Gentoo MySQL init scripts."
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+# This _will_ break with MySQL 5.0, 4.x, 3.x
+# It also NEEDS openrc for the save_options/get_options builtins.
+# The s6 support was added after openrc 0.16.2
+# mysql-connector-c needed for my_print_defaults
+RDEPEND="
+ !<dev-db/mysql-5.1
+ !<sys-apps/openrc-0.16.2
+ dev-db/mysql-connector-c
+ "
+# Need to set S due to PMS saying we need it existing, but no SRC_URI
+S=${WORKDIR}
+
+src_install() {
+ newconfd "${FILESDIR}/conf.d-2.0" "mysql"
+
+ # s6 init scripts
+ if use amd64 || use x86 ; then
+ newconfd "${FILESDIR}/conf.d-2.0" "mysql-s6"
+ newinitd "${FILESDIR}/init.d-s6-2.3" "mysql-s6"
+ s6_install_service mysql "${FILESDIR}/run-s6"
+ s6_install_service mysql/log "${FILESDIR}/log-s6"
+ fi
+
+ newinitd "${FILESDIR}/init.d-2.3" "mysql"
+ newinitd "${FILESDIR}/init.d-supervise-2.3" "mysql-supervise"
+
+ # systemd unit installation
+ exeinto /usr/libexec
+ doexe "${FILESDIR}"/mysqld-wait-ready
+ systemd_newunit "${FILESDIR}/mysqld-v2.service" "mysqld.service"
+ systemd_newunit "${FILESDIR}/mysqld_at-v2.service" "mysqld@.service"
+ dotmpfiles "${FILESDIR}/mysql.conf"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate.mysql-2.3" "mysql"
+}
+
+pkg_postinst() {
+ tmpfiles_process mysql.conf
+ if use amd64 || use x86 ; then
+ elog ""
+ elog "To use the mysql-s6 script, you need to install the optional sys-apps/s6 package."
+ elog "If you wish to use s6 logging support, comment out the log-error setting in your my.cnf"
+ fi
+
+ elog ""
+ elog "Starting with version 10.1.8, MariaDB includes an improved systemd unit named mariadb.service"
+ elog "You should prefer that unit over this package's mysqld.service."
+ einfo ""
+}