summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-09-16 20:22:00 -0400
committerBrian Evans <grknight@gentoo.org>2018-09-16 20:22:42 -0400
commit9b01922308ead1a7271b7a606747cb1eb43393a8 (patch)
tree2a89cd93abdb600d51f9d7095ea09140ae9befc3 /dev-db/mysql-super-smack
parentsys-apps/portage: remove old versions (diff)
downloadgentoo-9b01922308ead1a7271b7a606747cb1eb43393a8.tar.gz
gentoo-9b01922308ead1a7271b7a606747cb1eb43393a8.tar.bz2
gentoo-9b01922308ead1a7271b7a606747cb1eb43393a8.zip
dev-db/mysql-super-smack: Revbump for EAPI and dependency
Bug: https://bugs.gentoo.org/665852 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-db/mysql-super-smack')
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch4
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3-r4.ebuild66
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
index 23bcd56e019c..ec99b5da2217 100644
--- a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
@@ -1,5 +1,5 @@
---- src/dictionary.h.orig 2008-10-31 19:12:51.000000000 +0100
-+++ src/dictionary.h 2008-10-31 19:13:12.000000000 +0100
+--- a/src/dictionary.h.orig 2008-10-31 19:12:51.000000000 +0100
++++ b/src/dictionary.h 2008-10-31 19:13:12.000000000 +0100
@@ -23,6 +23,7 @@
#include <string>
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3-r4.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r4.ebuild
new file mode 100644
index 000000000000..cece7edde03f
--- /dev/null
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WANT_AUTOMAKE="1.13"
+
+inherit autotools libtool
+
+MY_PN="super-smack"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
+HOMEPAGE="http://vegan.net/tony/supersmack/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres"
+REQUIRED_USE="|| ( mysql postgres )"
+
+COMMON_DEPEND="sys-libs/zlib:=
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:*[server] )"
+DEPEND="${COMMON_DEPEND} sys-devel/bison sys-devel/flex"
+RDEPEND="${COMMON_DEPEND} mysql? ( virtual/mysql )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.destdir.patch
+ "${FILESDIR}"/${PN}-1.3.amd64.patch
+ "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
+ "${FILESDIR}"/${PN}-1.3-gen-data.patch
+ "${FILESDIR}"/${PN}-1.3-automake-1.13.patch
+)
+DOCS=( CHANGES INSTALL MANUAL README TUTORIAL )
+
+src_prepare() {
+ # Clean up files so eautoreconf does not pick up any
+ # deprecated autotools macros.
+ rm acinclude.m4 aclocal.m4 acconfig.h config.status config.h || die
+ mv configure.in configure.ac || die
+ export CXXFLAGS+=" -std=gnu++98"
+ default
+ eautoreconf
+ elibtoolize --patch-only
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(usex mysql --with-mysql "")
+ $(usex postgres --with-pgsql "")
+ --with-datadir=/var/tmp/${MY_PN}
+ --with-smacks-dir=/usr/share/${MY_PN}
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/tmp/${MY_PN}
+}
+
+pkg_postinst() {
+ elog "The gen-data binary is now installed as super-smack-gen-data"
+}