summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-03-20 17:12:35 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-04-10 00:21:27 +0200
commit2556f83e738d2737bb9d0de450ab713f5173515a (patch)
treeeb0ce28d9a8660616c4e82b9aa9242f8b78dda64 /dev-db/mysqltuner/mysqltuner-1.7.13.ebuild
parentnet-misc/casync: remove old. (diff)
downloadgentoo-2556f83e738d2737bb9d0de450ab713f5173515a.tar.gz
gentoo-2556f83e738d2737bb9d0de450ab713f5173515a.tar.bz2
gentoo-2556f83e738d2737bb9d0de450ab713f5173515a.zip
dev-db/mysqltuner: bump to version 1.7.13, EAPI 7.
Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11421 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.7.13.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.13.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.13.ebuild
new file mode 100644
index 000000000000..7b6bcca40eb4
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="http://www.mysqltuner.com/"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/mysql
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}