summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Satula <maksym.satula@gmail.com>2017-07-27 15:46:24 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 12:25:25 +0200
commit4206e6636d297eb834f8117d70ae89ac1ea00864 (patch)
treefa5ecb22f872e4dc878434f2d3de3dd806f4a85b /dev-db/ocp/ocp-9999.ebuild
parentx11-plugins/purple-hangouts: bump to 0_p20170714 (diff)
downloadgentoo-4206e6636d297eb834f8117d70ae89ac1ea00864.tar.gz
gentoo-4206e6636d297eb834f8117d70ae89ac1ea00864.tar.bz2
gentoo-4206e6636d297eb834f8117d70ae89ac1ea00864.zip
dev-db/ocp: New package
ocp is a command line tool to download and upload files from/to Oracle Database directories using Oracle SQL Net connection only Package-Manager: Portage-2.3.2, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5225
Diffstat (limited to 'dev-db/ocp/ocp-9999.ebuild')
-rw-r--r--dev-db/ocp/ocp-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
new file mode 100644
index 000000000000..3745af1f5a87
--- /dev/null
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient-basic
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+ default
+}