summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-05 00:14:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-05 22:27:41 +0100
commit93ceeb886d25b210422a410523105255e2198c25 (patch)
tree7b0e2f2e3fd5b12e669c285afd4eaa2563193962 /dev-db/pgadmin4
parentdev-db/pgadmin4: 4.17 version bump, python3_8 (diff)
downloadgentoo-93ceeb886d25b210422a410523105255e2198c25.tar.gz
gentoo-93ceeb886d25b210422a410523105255e2198c25.tar.bz2
gentoo-93ceeb886d25b210422a410523105255e2198c25.zip
dev-db/pgadmin4: Install desktop file
Closes: https://bugs.gentoo.org/689706 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-db/pgadmin4')
-rw-r--r--dev-db/pgadmin4/files/pgadmin4.desktop11
-rw-r--r--dev-db/pgadmin4/pgadmin4-4.17.ebuild10
2 files changed, 20 insertions, 1 deletions
diff --git a/dev-db/pgadmin4/files/pgadmin4.desktop b/dev-db/pgadmin4/files/pgadmin4.desktop
new file mode 100644
index 000000000000..e1697a620d5f
--- /dev/null
+++ b/dev-db/pgadmin4/files/pgadmin4.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=pgAdmin 4
+Exec=/usr/bin/pgAdmin4
+Icon=pgadmin4
+Type=Application
+Categories=Development;Database;
+MimeType=text/html
+DocPath=/usr/share/pgadmin4/docs/en_US/_build/html/index.html
+Comment=PostgreSQL Tools
+Keywords=database;db;sql;query;administration;development;
diff --git a/dev-db/pgadmin4/pgadmin4-4.17.ebuild b/dev-db/pgadmin4/pgadmin4-4.17.ebuild
index 626795b4964c..5fbbd435ceb6 100644
--- a/dev-db/pgadmin4/pgadmin4-4.17.ebuild
+++ b/dev-db/pgadmin4/pgadmin4-4.17.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"
-inherit python-single-r1 qmake-utils
+inherit desktop python-single-r1 qmake-utils xdg
DESCRIPTION="GUI administration and development platform for PostgreSQL"
HOMEPAGE="https://www.pgadmin.org/"
@@ -30,6 +30,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
"
DEPEND="${COMMON_DEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ virtual/imagemagick-tools[png]
"
RDEPEND="${COMMON_DEPEND}
>=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
@@ -103,4 +104,11 @@ src_install() {
insinto /usr/share/${PN}/docs/en_US/_build
doins -r docs/en_US/_build/html
fi
+
+ local s
+ for s in 16 32 48 64 72 96 128 192 256; do
+ convert runtime/pgAdmin4.png -resize ${s}x${s} ${PN}_${s}.png || die
+ newicon -s ${s} ${PN}_${s}.png ${PN}.png
+ done
+ domenu "${FILESDIR}"/${PN}.desktop
}