summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-10-02 21:41:26 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-10-02 21:59:43 -0400
commit9d6096a26797a9a97098db1da96a61c894197ab0 (patch)
tree999fa81283ab9b632951b5c0f96578c595c6e18f /dev-db/pgbouncer
parentdev-lang/php: Drop old (diff)
downloadgentoo-9d6096a26797a9a97098db1da96a61c894197ab0.tar.gz
gentoo-9d6096a26797a9a97098db1da96a61c894197ab0.tar.bz2
gentoo-9d6096a26797a9a97098db1da96a61c894197ab0.zip
dev-db/pgbouncer: Cleanup
Closes: https://bugs.gentoo.org/654136 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgbouncer')
-rw-r--r--dev-db/pgbouncer/Manifest1
-rw-r--r--dev-db/pgbouncer/files/pgbouncer.confd12
-rwxr-xr-xdev-db/pgbouncer/files/pgbouncer.initd-r183
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.8.1.ebuild86
4 files changed, 0 insertions, 182 deletions
diff --git a/dev-db/pgbouncer/Manifest b/dev-db/pgbouncer/Manifest
index 1bea33dfbbaa..11cc6304a317 100644
--- a/dev-db/pgbouncer/Manifest
+++ b/dev-db/pgbouncer/Manifest
@@ -1,2 +1 @@
-DIST pgbouncer-1.8.1.tar.gz 465930 BLAKE2B 692c551cb7bfb56bfe1b354791b06bdf61866197150a78a7fa9688891a2e4cd3c015abc5fbe33bf66dc85ab0ae83745f2db852eae91ae99596c97be0154e8bd5 SHA512 595a94db98866cec211f2b8c1ad13d209dba00e5fd41f2e9025aabdcb660194f0f772810270a1d9f067c3039c9fee630e8ff2d56f231935add17207aecc10bee
DIST pgbouncer-1.9.0.tar.gz 469300 BLAKE2B 466f171a49ec9ce9be9a9d3208780cfbff956da7c74ec4332c7104ea537cb47a5cfdc0d80bbd96d233769b6f430f1ad99b623caefa2dc93af7ba336dd0f49514 SHA512 b127f4cb60ca5cdf339da76727918f0a3797a3e0a89f8ed6fdcaa80f3391d2c5bb51e19731915775210c0e5070dd611ee2e410c9a947624e45b5cf11aecdacf9
diff --git a/dev-db/pgbouncer/files/pgbouncer.confd b/dev-db/pgbouncer/files/pgbouncer.confd
deleted file mode 100644
index e2c584011884..000000000000
--- a/dev-db/pgbouncer/files/pgbouncer.confd
+++ /dev/null
@@ -1,12 +0,0 @@
-# Location of configuration file for PgBouncer.
-INIFILE="/etc/pgbouncer.ini"
-
-# How long to wait in seconds for a safe shutdown. Equivalent to
-# issuing 'PAUSE;' and 'SHUTDOWN;' on psql console. (See 'man 1 pgbouncer'.)
-NICE_TIMEOUT=60
-
-# Set to 'YES' to perform an immediate shutdown if the nice shutdown
-# doesn't work. Same as issuing 'SHUTDOWN;' on console. (See 'man 1
-# pgbouncer'.)
-FORCE_QUIT="no"
-FORCE_QUIT_TIMEOUT=2 \ No newline at end of file
diff --git a/dev-db/pgbouncer/files/pgbouncer.initd-r1 b/dev-db/pgbouncer/files/pgbouncer.initd-r1
deleted file mode 100755
index 7392918593bb..000000000000
--- a/dev-db/pgbouncer/files/pgbouncer.initd-r1
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/sbin/openrc-run
-
-extra_started_commands="reload"
-
-PIDFILE="/run/pgbouncer.pid"
-
-depend() {
- use net
- after postgresql
-}
-
-get_config() {
- [ -f "${INIFILE}" ] || eend 1 "'${INIFILE}' not found"
-
- eval echo $(sed -e 's:;.*::' "${INIFILE}" | \
- awk '$1 == "'$1'" { print ($2 == "=" ? $3 : $2) }')
-}
-
-start_pre() {
- local s="$(get_config unix_socket_dir)"
-
- if [ -n "${s}" ] ; then
- checkpath -o root:postgres -m 1775 -d "${s}" || return 1
-
- local listen_port="$(get_config listen_port)"
-
- if [ -e "${s%/}/.s.PGSQL.${listen_port}" ] ; then
- eerror "Socket conflict."
- eerror "A server is already listening on:"
- eerror " ${s%/}/.s.PGSQL.${listen_port}"
- eerror "HINT: Change listen_port in pgbouncer.ini to listen on a"
- eerror "different socket."
- return 1
- fi
- fi
-
- checkpath -o pgbouncer:postgres -m 0755 \
- -d "$(dirname $(get_config logfile))" || return 1
- checkpath -o pgbouncer:postgres -m 0640 \
- -f "$(get_config logfile)" || return 1
-
- return 0
-}
-
-start() {
- ebegin "Starting PgBouncer"
- [ -f ${PIDFILE} ] && rm ${PIDFILE}
-
- start-stop-daemon --start \
- --pidfile ${PIDFILE} \
- --background \
- --make-pidfile \
- --user pgbouncer \
- --exec /usr/bin/pgbouncer \
- -- -q "${INIFILE}"
- eend $?
-}
-
-stop() {
- local seconds=$(( ${NICE_TIMEOUT} + ${FORCE_QUIT_TIMEOUT} ))
- ebegin "Stopping PgBouncer (this can take up to ${seconds} seconds)"
-
- local retries=SIGINT/${NICE_TIMEOUT}
-
- if [ "${FORCE_QUIT}" = "YES" ] ; then
- einfo "FORCE_QUIT enabled."
- retries="${retries}/SIGTERM/${FORCE_QUIT_TIMEOUT}"
- fi
-
- # Loops through nice and force quit in one go.
- start-stop-daemon --stop \
- --user pgbouncer \
- --pidfile ${PIDFILE} \
- --retry ${retries}
-
- eend $?
-}
-
-reload() {
- ebegin "Reloading PgBouncer configuration from '${INIFILE}'"
- start-stop-daemon --signal HUP --pidfile ${PIDFILE}
- eend $?
-}
diff --git a/dev-db/pgbouncer/pgbouncer-1.8.1.ebuild b/dev-db/pgbouncer/pgbouncer-1.8.1.ebuild
deleted file mode 100644
index f590a731732e..000000000000
--- a/dev-db/pgbouncer/pgbouncer-1.8.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit user
-
-DESCRIPTION="Lightweight connection pooler for PostgreSQL"
-HOMEPAGE="https://pgbouncer.github.io"
-SRC_URI="https://pgbouncer.github.io/downloads/files/${PV}/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+c-ares debug doc pam ssl -udns"
-
-# At-most-one-of, one can be enabled but not both
-REQUIRED_USE="?? ( c-ares udns )"
-
-RDEPEND="
- >=dev-libs/libevent-2.0
- >=sys-libs/glibc-2.10
- c-ares? ( >=net-dns/c-ares-1.10 )
- ssl? ( >=dev-libs/openssl-1.0.1:=[-bindist] )
- udns? ( >=net-libs/udns-0.1 )
-"
-
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- enewgroup postgres 70
- enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
-
- enewuser pgbouncer -1 -1 -1 postgres
-}
-
-src_prepare() {
- eapply "${FILESDIR}/pgbouncer-1.8-dirs.patch"
-
- default
-}
-
-src_configure() {
- # --enable-debug is only used to disable stripping
- econf \
- --docdir=/usr/share/doc/${PF} \
- --enable-debug \
- $(use_with c-ares cares) \
- $(use_enable debug cassert) \
- $(use_with pam) \
- $(use_with ssl openssl) \
- $(use_with udns)
-}
-
-src_test() {
- cd "${S}/test"
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS
- use doc && dodoc doc/*.rst
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd-r1" "${PN}"
-
- insinto /etc
- doins etc/pgbouncer.ini
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/logrotate" pgbouncer
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- einfo "Please read the config.txt for Configuration Directives"
- einfo
- einfo "For Administration Commands, see:"
- einfo " man pgbouncer"
- einfo
- einfo "By default, PgBouncer does not have access to any database."
- einfo "GRANT the permissions needed for your application and make sure that it"
- einfo "exists in PgBouncer's auth_file."
- fi
-}