summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-18 18:49:25 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-16 10:33:30 +0200
commitb99552045c16fe4943a734bd08aafcbcaad2da87 (patch)
tree96607ab5866be5e559151fa67429dee7e0f1b0a2 /dev-db/pgcli
parentdev-python/pendulum: Drop-in replacement for the standard datetime class (diff)
downloadgentoo-b99552045c16fe4943a734bd08aafcbcaad2da87.tar.gz
gentoo-b99552045c16fe4943a734bd08aafcbcaad2da87.tar.bz2
gentoo-b99552045c16fe4943a734bd08aafcbcaad2da87.zip
dev-db/pgcli: Bump to 3.1.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/18714 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/pgcli')
-rw-r--r--dev-db/pgcli/Manifest1
-rw-r--r--dev-db/pgcli/pgcli-3.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/pgcli/Manifest b/dev-db/pgcli/Manifest
index d8cf8aab7359..f22aac8bbf3f 100644
--- a/dev-db/pgcli/Manifest
+++ b/dev-db/pgcli/Manifest
@@ -1 +1,2 @@
DIST pgcli-3.0.0.tar.gz 437733 BLAKE2B 5db69997f675812c3ef847b220b66e7872b134b4d8debd668154bdfa6020432ac08829e7c2ce42adc4cf124e84de5eb9aacbe19636216502f81373a71f21b68f SHA512 7ac52cbfc492dc85163dac7df7a5dde6bfa0327ac1ef6580891cb76d617b998d74c2a59b27d2f8abf8699eb5a69aba30bf13e95ad7bee75c83350730ac061262
+DIST pgcli-3.1.0.tar.gz 441939 BLAKE2B 2c9c9a3afb233eee6f88d304e26e482760f1ff2a458103a80ffb80d877f63bd3ec74ba4be06238e8d78adf36ec251cd27849e0899f3b257b75ac9585f3c04572 SHA512 458871bf7ea0a83a66f44ecbde88590ca2aa08420a58c97d2716d4e36c61738d92283d007fc3968063daa01c25b2c46360292ad6339757c119ff04891e1a1c46
diff --git a/dev-db/pgcli/pgcli-3.1.0.ebuild b/dev-db/pgcli/pgcli-3.1.0.ebuild
new file mode 100644
index 000000000000..453cba7d70d4
--- /dev/null
+++ b/dev-db/pgcli/pgcli-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/pgcli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cli_helpers[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pendulum[${PYTHON_USEDEP}]
+ dev-python/pgspecial[${PYTHON_USEDEP}]
+ dev-python/prompt_toolkit[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/sqlparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-db/postgresql
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest