summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-12-16 23:02:34 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-12-16 23:02:34 -0500
commit55cb29cdcea2e22381b97ddac899d44bd4e9e673 (patch)
tree3291de1c9891f783a2418c07a1004f8753b0fc4e /dev-db/pgpool2
parentdev-libs/libgit2: Stabilize 1.1.0-r2 arm64, #760219 (diff)
downloadgentoo-55cb29cdcea2e22381b97ddac899d44bd4e9e673.tar.gz
gentoo-55cb29cdcea2e22381b97ddac899d44bd4e9e673.tar.bz2
gentoo-55cb29cdcea2e22381b97ddac899d44bd4e9e673.zip
dev-db/pgpool2: Bump to 4.2.0
Now supports Pg 12 and 13. Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgpool2')
-rw-r--r--dev-db/pgpool2/Manifest1
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch60
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch14
-rw-r--r--dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch432
-rw-r--r--dev-db/pgpool2/pgpool2-4.2.0.ebuild98
5 files changed, 605 insertions, 0 deletions
diff --git a/dev-db/pgpool2/Manifest b/dev-db/pgpool2/Manifest
index 6ab46044a513..e8e714bd2155 100644
--- a/dev-db/pgpool2/Manifest
+++ b/dev-db/pgpool2/Manifest
@@ -1,2 +1,3 @@
DIST pgpool-II-3.7.10.tar.gz 3375419 BLAKE2B 96d589e9a3eff631bd4bffdcf321b3b532e5f0985dd4a5948fabc3228400305dc98fbf17ba64e162ecbaecca400e1bb3cad6fc954b2d624292f6f22deb48a789 SHA512 a89c392e336f5dd608c6876011f996fa1e4d7cb4b0eef31c24b2338ac287b72b73948e82429715d38fd9a7a6598f56828192722a2a8ee0d473738b804c4a2a48
DIST pgpool-II-4.0.5.tar.gz 3768842 BLAKE2B 2756d23db950a037a9203aae41293535de25d11bf9860f509040bf5b483ae5fb9e651c8189ee5f0a9398a45d20d2c54566769945e38c52361c160a1162a8e3af SHA512 897df553dba3a1800adae5d22ed4f4fe210a3013fb533730837591244877eeaf0e4090d1a0c65e189b71798b5c303ea22e2198f6317b54f74f10ba48fa2188c6
+DIST pgpool-II-4.2.0.tar.gz 4707623 BLAKE2B 9aa54fe0230d5dab303e9b20f35c242f9fe7f09c4c506c72be3a5d789f4e5c23b6e6fdf529ddafd5b1a0c0697a1e1b0f0106f965a8409f8e012633b8be0a58a9 SHA512 73179c3968441b592503512c5e0dfcc95ef778ecfd077024df0485fe831c9af12e708b51607c96c7bebf26f3cc81aefc53f50c7ad0a670d304cbbcf852170abf
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch b/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch
new file mode 100644
index 000000000000..9854e45e3a22
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-configure-memcached.patch
@@ -0,0 +1,60 @@
+diff -Naruw pgpool-II-4.2.0.orig/configure.ac pgpool-II-4.2.0/configure.ac
+--- pgpool-II-4.2.0.orig/configure.ac 2020-11-25 20:25:42.000000000 -0500
++++ pgpool-II-4.2.0/configure.ac 2020-12-16 06:36:26.051076452 -0500
+@@ -392,37 +392,24 @@
+ fi
+
+
+-AC_ARG_WITH(memcached,
+- [ --with-memcached=DIR site header files for libmemcached in DIR],
+- [
+- case "$withval" in
+- "" | y | ye | yes | n | no)
+- AC_MSG_ERROR([*** You must supply an argument to the --with-memcached option.])
+- ;;
+- *)
+-
+- MEMCACHED_INCLUDE_DIR="$withval"/include
+- MEMCACHED_LIB_DIR="$withval"/lib
+- OLD_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -I$MEMCACHED_INCLUDE_DIR"
++AC_ARG_WITH([memcached],
++ AS_HELP_STRING([--with-memcached], [Build with memcached support]))
++AS_IF([test "x$with_memcached" = "xyes"], [
++ PKG_CHECK_MODULES([MEMCACHED], [libmemcached])
++ CFLAGS="$CFLAGS $MEMCACHED_CFLAGS"
++ LIBS="$LIBS $MEMCACHED_LIBS"
++
+ AC_CHECK_HEADERS(
+ [libmemcached/memcached.h],
+ [AC_DEFINE([USE_MEMCACHED], 1, [Define to 1 to build with memcached support])],
+- [AC_MSG_ERROR([header file <libmemcached/memcached.h> is required for memcached support])])
+- CFLAGS=$OLD_CFLAGS
+- AC_CHECK_LIB(memcached, memcached_create, [], [AC_MSG_ERROR(libmemcached is not installed)])
+- MEMCACHED_INCLUDE_OPT="-I $MEMCACHED_INCLUDE_DIR"
+- MEMCACHED_LINK_OPT="-L$MEMCACHED_LIB_DIR"
+- MEMCACHED_RPATH_OPT="-rpath $MEMCACHED_LIB_DIR"
+- ;;
+- esac
++ [AC_MSG_ERROR([Couldn't find <libmemcached/memcached.h>])])
++
++ AC_SEARCH_LIBS(memcached_create, [], [],
++ [AC_MSG_ERROR(libmemcached is not installed)])
+ ])
+
+ CFLAGS="$CFLAGS -fno-strict-aliasing"
+
+-AC_SUBST(MEMCACHED_INCLUDE_OPT)
+-AC_SUBST(MEMCACHED_LINK_OPT)
+-AC_SUBST(MEMCACHED_RPATH_OPT)
+
+ OLD_LDFLAGS="$LDFLAGS"
+ LDFLAGS="-L$PGSQL_LIB_DIR $LDFLAGS"
+@@ -435,7 +422,6 @@
+ AC_SUBST(PGSQL_INCLUDE_DIR)
+ AC_SUBST(PGSQL_LIB_DIR)
+ AC_SUBST(PGSQL_BIN_DIR)
+-AC_SUBST(MEMCACHED_DIR)
+
+ # --enable(disable)-rpath option
+ AC_ARG_ENABLE(rpath,
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch b/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch
new file mode 100644
index 000000000000..842fd5fbad73
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-configure-pthread.patch
@@ -0,0 +1,14 @@
+diff -Naruw pgpool-II-4.2.0.orig/configure.ac pgpool-II-4.2.0/configure.ac
+--- pgpool-II-4.2.0.orig/configure.ac 2020-11-25 20:25:42.000000000 -0500
++++ pgpool-II-4.2.0/configure.ac 2020-12-16 06:40:11.150611861 -0500
+@@ -4,6 +4,10 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CC_C99()
++AX_PTHREAD
++LIBS="$PTHREAD_LIBS $LIBS"
++CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
++CC="$PTHREAD_CC"
+
+ # Error out if the compiler does not support C99, as the codebase
+ # relies on that.
diff --git a/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch b/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch
new file mode 100644
index 000000000000..fd5dd863d7b1
--- /dev/null
+++ b/dev-db/pgpool2/files/pgpool-4.2.0-run_paths.patch
@@ -0,0 +1,432 @@
+diff -Naruw pgpool-II-4.2.0.orig/src/include/parser/pg_config_manual.h pgpool-II-4.2.0/src/include/parser/pg_config_manual.h
+--- pgpool-II-4.2.0.orig/src/include/parser/pg_config_manual.h 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/include/parser/pg_config_manual.h 2020-12-16 21:39:27.178596628 -0500
+@@ -228,7 +228,7 @@
+ * support them yet.
+ */
+ #ifndef WIN32
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+ #else
+ #define DEFAULT_PGSOCKET_DIR ""
+ #endif
+diff -Naruw pgpool-II-4.2.0.orig/src/include/pcp/pcp_stream.h pgpool-II-4.2.0/src/include/pcp/pcp_stream.h
+--- pgpool-II-4.2.0.orig/src/include/pcp/pcp_stream.h 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/include/pcp/pcp_stream.h 2020-12-16 21:40:46.051752707 -0500
+@@ -49,6 +49,6 @@
+ extern int pcp_write(PCP_CONNECTION * pc, void *buf, int len);
+ extern int pcp_flush(PCP_CONNECTION * pc);
+
+-#define UNIX_DOMAIN_PATH "/tmp"
++#define UNIX_DOMAIN_PATH "/run/pgpool"
+
+ #endif /* PCP_STREAM_H */
+diff -Naruw pgpool-II-4.2.0.orig/src/include/pool.h pgpool-II-4.2.0/src/include/pool.h
+--- pgpool-II-4.2.0.orig/src/include/pool.h 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/include/pool.h 2020-12-16 21:42:50.054807364 -0500
+@@ -69,16 +69,16 @@
+ #define HBA_CONF_FILE_NAME "pool_hba.conf"
+
+ /* pid file directory */
+-#define DEFAULT_LOGDIR "/tmp"
++#define DEFAULT_LOGDIR "/run/pgpool"
+
+ /* Unix domain socket directory */
+-#define DEFAULT_SOCKET_DIR "/tmp"
++#define DEFAULT_SOCKET_DIR "/run/postgresql"
+
+ /* Unix domain socket directory for watchdog IPC */
+-#define DEFAULT_WD_IPC_SOCKET_DIR "/tmp"
++#define DEFAULT_WD_IPC_SOCKET_DIR "/run/pgpool"
+
+ /* pid file name */
+-#define DEFAULT_PID_FILE_NAME "/var/run/pgpool/pgpool.pid"
++#define DEFAULT_PID_FILE_NAME "/run/pgpool/pgpool.pid"
+
+ /* status file name */
+ #define STATUS_FILE_NAME "pgpool_status"
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample pgpool-II-4.2.0/src/sample/pgpool.conf.sample
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample 2020-12-16 21:57:56.776102951 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -659,10 +655,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-logical pgpool-II-4.2.0/src/sample/pgpool.conf.sample-logical
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-logical 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-logical 2020-12-16 21:57:56.776102951 -0500
+@@ -38,10 +38,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -58,10 +56,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -621,10 +617,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-raw pgpool-II-4.2.0/src/sample/pgpool.conf.sample-raw
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-raw 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-raw 2020-12-16 21:57:56.776102951 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -287,13 +283,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -660,10 +656,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Virtual IP control Setting -
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-replication pgpool-II-4.2.0/src/sample/pgpool.conf.sample-replication
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-replication 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-replication 2020-12-16 21:57:56.776102951 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -282,13 +278,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -657,10 +653,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-slony pgpool-II-4.2.0/src/sample/pgpool.conf.sample-slony
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-slony 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-slony 2020-12-16 21:57:56.776102951 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -283,13 +279,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -658,10 +654,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Virtual IP control Setting -
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-snapshot pgpool-II-4.2.0/src/sample/pgpool.conf.sample-snapshot
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-snapshot 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-snapshot 2020-12-16 21:57:56.779436277 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -65,10 +63,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+ # - Backend Connection Settings -
+@@ -280,13 +276,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -655,10 +651,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
+diff -Naruw pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-stream pgpool-II-4.2.0/src/sample/pgpool.conf.sample-stream
+--- pgpool-II-4.2.0.orig/src/sample/pgpool.conf.sample-stream 2020-11-25 20:25:31.000000000 -0500
++++ pgpool-II-4.2.0/src/sample/pgpool.conf.sample-stream 2020-12-16 21:57:56.779436277 -0500
+@@ -39,10 +39,8 @@
+ port = 9999
+ # Port number
+ # (change requires restart)
+-socket_dir = '/tmp'
++socket_dir = '/run/postgresql'
+ # Unix domain socket path
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ reserved_connections = 0
+ # Number of reserved connections.
+@@ -59,10 +57,8 @@
+ pcp_port = 9898
+ # Port number for pcp
+ # (change requires restart)
+-pcp_socket_dir = '/tmp'
++pcp_socket_dir = '/run/pgpool'
+ # Unix domain socket path for pcp
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+ listen_backlog_multiplier = 2
+ # Set the backlog parameter of listen(2) to
+@@ -286,13 +282,13 @@
+ # FILE LOCATIONS
+ #------------------------------------------------------------------------------
+
+-pid_file_name = '/var/run/pgpool/pgpool.pid'
++pid_file_name = '/run/pgpool/pgpool.pid'
+ # PID file name
+ # Can be specified as relative to the"
+ # location of pgpool.conf file or
+ # as an absolute path
+ # (change requires restart)
+-logdir = '/tmp'
++logdir = '/run/pgpool'
+ # Directory of pgPool status file
+ # (change requires restart)
+
+@@ -659,10 +655,8 @@
+ # Authentication key for watchdog communication
+ # (change requires restart)
+
+-wd_ipc_socket_dir = '/tmp'
++wd_ipc_socket_dir = '/run/pgpool'
+ # Unix domain socket path for watchdog IPC socket
+- # The Debian package defaults to
+- # /var/run/postgresql
+ # (change requires restart)
+
+
diff --git a/dev-db/pgpool2/pgpool2-4.2.0.ebuild b/dev-db/pgpool2/pgpool2-4.2.0.ebuild
new file mode 100644
index 000000000000..9e4cb8b88377
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-4.2.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+
+inherit autotools postgres-multi
+
+MY_P="${PN/2/-II}-${PV}"
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="https://www.pgpool.net/"
+SRC_URI="https://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="amd64 x86"
+
+IUSE="doc libressl memcached pam ssl static-libs"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ net-libs/libnsl:0=
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ postgres_new_user pgpool
+
+ postgres-multi_pkg_setup
+}
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}/pgpool-4.2.0-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-configure-pam.patch" \
+ "${FILESDIR}/pgpool-4.2.0-configure-pthread.patch" \
+ "${FILESDIR}/pgpool-4.2.0-run_paths.patch"
+
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ postgres-multi_foreach econf \
+ --disable-rpath \
+ --sysconfdir="${EROOT%/}/etc/${PN}" \
+ --with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
+ --with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
+ $(use_enable static-libs static) \
+ $(use_with memcached) \
+ $(use_with pam) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ # Even though we're only going to do an install for the best slot
+ # available, the extension bits in src/sql need some things outside
+ # of that directory built, too.
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C src/sql
+}
+
+src_install() {
+ # We only need the best stuff installed
+ postgres-multi_forbest emake DESTDIR="${D}" install
+
+ # Except for the extension and .so files that each PostgreSQL slot needs
+ postgres-multi_foreach emake DESTDIR="${D}" -C src/sql install
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation!
+ dodoc NEWS TODO
+ doman doc/src/sgml/man{1,8}/*
+ use doc && dodoc -r doc/src/sgml/html
+
+ # mv some files that get installed to /usr/share/pgpool-II so that
+ # they all wind up in the same place
+ mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}