summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-02-21 15:25:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-02-21 15:26:18 +0000
commitd56751d773a6e226f07bf471461b77da3267be28 (patch)
tree15ecd9bd44f8b174c12e1a4c1a25631c40f059fb /dev-db/postgresql
parentdev-python/coverage: Fix tests (diff)
downloadgentoo-d56751d773a6e226f07bf471461b77da3267be28.tar.gz
gentoo-d56751d773a6e226f07bf471461b77da3267be28.tar.bz2
gentoo-d56751d773a6e226f07bf471461b77da3267be28.zip
dev-db/postgresql: add zstd support to -9999
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index c922ae2da90f..f290a4330a72 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -18,9 +18,9 @@ LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
HOMEPAGE="https://www.postgresql.org/"
-IUSE="debug icu kerberos ldap llvm lz4
+IUSE="debug icu kerberos ldap llvm +lz4
nls pam perl python +readline selinux server systemd
- ssl static-libs tcl threads uuid xml zlib"
+ ssl static-libs tcl threads uuid xml zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -48,6 +48,7 @@ tcl? ( >=dev-lang/tcl-8:0= )
uuid? ( dev-libs/ossp-uuid )
xml? ( dev-libs/libxml2 dev-libs/libxslt )
zlib? ( sys-libs/zlib )
+zstd? ( app-arch/zstd )
"
# uuid flags -- depend on sys-apps/util-linux for Linux libcs, or if no
@@ -173,6 +174,7 @@ src_configure() {
$(use_with xml libxml) \
$(use_with xml libxslt) \
$(use_with zlib) \
+ $(use_with zstd ) \
$(use_with systemd) \
${uuid_config}"
if use alpha; then