summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/psqlodbc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/psqlodbc')
-rw-r--r--dev-db/psqlodbc/Manifest3
-rw-r--r--dev-db/psqlodbc/metadata.xml8
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.01.0200.ebuild42
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild42
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.03.0210.ebuild42
5 files changed, 137 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/Manifest b/dev-db/psqlodbc/Manifest
new file mode 100644
index 000000000000..091f3befd1ca
--- /dev/null
+++ b/dev-db/psqlodbc/Manifest
@@ -0,0 +1,3 @@
+DIST psqlodbc-09.01.0200.tar.gz 749712 SHA256 89c230f5068dcd17d5c6dab37d13ed03525040da534cc7f49564dceba00a9c2c SHA512 6b1ce9efead84c1f5805561c150d5d6d4fba719472e43332987159918762098e1c41822fe804b4c9732e5fcb19beebd9b5f72ef756c021b764d6582f17bf4565 WHIRLPOOL e200c2014c58055a6ee69decea6f9ff92ad1166d2224c714a1634302ea621308e362760527617d2011db8ccaffcf7f35217431f705a9145f65777ee7a788e9e7
+DIST psqlodbc-09.02.0100.tar.gz 738231 SHA256 6701525030a8c927059f972ebd65e83a41f7f177228cd8e894654893d86cb93c SHA512 5d2eae82596b3a120b00c140441c47af065a201236fef9aa086372f2207bab2f2bffee7d0db177a64c370118eaa4348509dcb3e99a40f564d26d4e938c57cc68 WHIRLPOOL e300672c7608e28af52befbb62a16c8584a709b75fc12edeadf37b2d26a8cdd64a390af026ec752408818d053d51202c829b6ad62d82a543dbce21ce6624d3c0
+DIST psqlodbc-09.03.0210.tar.gz 784548 SHA256 42f2a57ec65c8a2edb0736f57b03c510986f33a9178d3d695616734dcc5e96d9 SHA512 da6b8da28c8ddd0912c57b7c1b8a2b494446b07ef7c6db8b56006b0c26705f64d413bdfed64b99e8baf6db70f1b578e818ad9ead357d16a8765deff7121c0a44 WHIRLPOOL 03f191421d95ab7b7da3c7806fc0081d66588bf5d860097fd9a239219d59ebdbe56790bf62786fb145f6378b60fdeb37ac74196f41de7e6ae7ac5551ba6f47c2
diff --git a/dev-db/psqlodbc/metadata.xml b/dev-db/psqlodbc/metadata.xml
new file mode 100644
index 000000000000..9275f1aa9e94
--- /dev/null
+++ b/dev-db/psqlodbc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>postgresql</herd>
+<use>
+<flag name='iodbc'>Use dev-db/libiodbc. Disable to use dev-db/unixODBC.</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-db/psqlodbc/psqlodbc-09.01.0200.ebuild b/dev-db/psqlodbc/psqlodbc-09.01.0200.ebuild
new file mode 100644
index 000000000000..43da089697d7
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.01.0200.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_MAJOR=$(get_major_version)
+MY_MINOR=$(get_version_component_range 2)
+PGSLOT="${MY_MAJOR#0}.${MY_MINOR#0}"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql:${PGSLOT}
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-libpq="${EROOT%/}/usr/$(get_libdir)/postgresql-${PGSLOT}/bin/pg_config" \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable ssl openssl) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dohtml docs/*
+}
diff --git a/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild b/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild
new file mode 100644
index 000000000000..43da089697d7
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.02.0100.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_MAJOR=$(get_major_version)
+MY_MINOR=$(get_version_component_range 2)
+PGSLOT="${MY_MAJOR#0}.${MY_MINOR#0}"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql:${PGSLOT}
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-libpq="${EROOT%/}/usr/$(get_libdir)/postgresql-${PGSLOT}/bin/pg_config" \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable ssl openssl) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dohtml docs/*
+}
diff --git a/dev-db/psqlodbc/psqlodbc-09.03.0210.ebuild b/dev-db/psqlodbc/psqlodbc-09.03.0210.ebuild
new file mode 100644
index 000000000000..43da089697d7
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.03.0210.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib versionator
+
+MY_MAJOR=$(get_major_version)
+MY_MINOR=$(get_version_component_range 2)
+PGSLOT="${MY_MAJOR#0}.${MY_MINOR#0}"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql:${PGSLOT}
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+ ssl? ( dev-libs/openssl )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --with-libpq="${EROOT%/}/usr/$(get_libdir)/postgresql-${PGSLOT}/bin/pg_config" \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable ssl openssl) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dohtml docs/*
+}