summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-08-14 20:09:02 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2018-08-14 20:09:45 -0700
commit248dbab6baed691d61011be1a4115b25e2f05e4f (patch)
treefc1440758d14b2823f0b575474fa8cfae978fd2f /dev-db/redis/files
parentdev-libs/xmlsec: amd64 stable wrt bug #663584 (diff)
downloadgentoo-248dbab6baed691d61011be1a4115b25e2f05e4f.tar.gz
gentoo-248dbab6baed691d61011be1a4115b25e2f05e4f.tar.bz2
gentoo-248dbab6baed691d61011be1a4115b25e2f05e4f.zip
dev-db/redis: cleanup old ebuilds
Bug: https://bugs.gentoo.org/631002 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-db/redis/files')
-rw-r--r--dev-db/redis/files/configure.ac-2.258
-rw-r--r--dev-db/redis/files/redis-2.8.17-config.patch46
-rw-r--r--dev-db/redis/files/redis-2.8.3-shared.patch36
-rw-r--r--dev-db/redis/files/redis-3.0.0-sharedlua.patch44
-rw-r--r--dev-db/redis/files/redis.confd20
-rw-r--r--dev-db/redis/files/redis.initd-431
6 files changed, 0 insertions, 235 deletions
diff --git a/dev-db/redis/files/configure.ac-2.2 b/dev-db/redis/files/configure.ac-2.2
deleted file mode 100644
index 3ff6650407ca..000000000000
--- a/dev-db/redis/files/configure.ac-2.2
+++ /dev/null
@@ -1,58 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.63)
-AC_INIT(redis, 2.0.0, antirez@gmail.com)
-AM_CFLAGS="-std=c99 -pedantic -Wall -W -D__EXTENSIONS__ -D_XPG6"
-if test x"$CFLAGS" = x""; then
- AM_CFLAGS="$AM_CFLAGS -O2"
-else
- AM_CFLAGS="$AM_CFLAGS $CFLAGS"
-fi
-
-# options
-AC_MSG_CHECKING([whether to build with debug information])
-AC_ARG_ENABLE([debug],
- [AS_HELP_STRING([--enable-debug],
- [enable debug data generation (def=no)])],
- [debugit="$enableval"],
- [debugit=no])
-AC_MSG_RESULT([$debugit])
-
-if test x"$debugit" = x"yes"; then
- AC_DEFINE([DEBUG],[],[Debug Mode])
- AM_CFLAGS="$AM_CFLAGS -g -rdynamic -ggdb"
-else
- AC_DEFINE([NDEBUG],[],[No-debug Mode])
-fi
-AC_SUBST([AM_CFLAGS])
-
-# Checks for programs.
-AC_PROG_CC
-
-# Checks for libraries.
-
-# Checks for header files.
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h unistd.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_STDBOOL
-AC_C_INLINE
-AC_TYPE_INT16_T
-AC_TYPE_INT32_T
-AC_TYPE_OFF_T
-AC_TYPE_PID_T
-AC_TYPE_SIZE_T
-AC_TYPE_SSIZE_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-
-# Checks for library functions.
-AC_FUNC_ERROR_AT_LINE
-AC_FUNC_FORK
-AC_FUNC_STRCOLL
-AC_FUNC_STRTOD
-AC_CHECK_FUNCS([dup2 gethostbyname gettimeofday inet_ntoa memchr memmove memset select socket strcasecmp strchr strerror strstr strtol])
-
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT
diff --git a/dev-db/redis/files/redis-2.8.17-config.patch b/dev-db/redis/files/redis-2.8.17-config.patch
deleted file mode 100644
index c9f6b2af172b..000000000000
--- a/dev-db/redis/files/redis-2.8.17-config.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/redis.conf 2014-12-02 16:22:38.722433643 +0100
-+++ b/redis.conf 2014-12-02 16:22:16.252249350 +0100
-@@ -38,7 +38,7 @@
-
- # When running daemonized, Redis writes a pid file in /var/run/redis.pid by
- # default. You can specify a custom pid file location here.
--pidfile /var/run/redis.pid
-+pidfile /run/redis/redis.pid
-
- # Accept connections on the specified port, default is 6379.
- # If port 0 is specified Redis will not listen on a TCP socket.
-@@ -61,7 +61,7 @@
- # Examples:
- #
- # bind 192.168.1.100 10.0.0.1
--# bind 127.0.0.1
-+bind 127.0.0.1
-
- # Specify the path for the Unix socket that will be used to listen for
- # incoming connections. There is no default, so Redis will not listen
-@@ -100,7 +100,7 @@
- # Specify the log file name. Also the empty string can be used to force
- # Redis to log on the standard output. Note that if you use standard
- # output for logging but daemonize, logs will be sent to /dev/null
--logfile ""
-+logfile /var/log/redis/redis.log
-
- # To enable logging to the system logger, just set 'syslog-enabled' to yes,
- # and optionally update the other syslog parameters to suit your needs.
-@@ -184,7 +184,7 @@
- # The Append Only File will also be created inside this directory.
- #
- # Note that you must specify a directory here, not a file name.
--dir ./
-+dir /var/lib/redis/
-
- ################################# REPLICATION #################################
-
-@@ -403,6 +403,7 @@
- # output buffers (but this is not needed if the policy is 'noeviction').
- #
- # maxmemory <bytes>
-+maxmemory 67108864
-
- # MAXMEMORY POLICY: how Redis will select what to remove when maxmemory
- # is reached. You can select among five behaviors:
diff --git a/dev-db/redis/files/redis-2.8.3-shared.patch b/dev-db/redis/files/redis-2.8.3-shared.patch
deleted file mode 100644
index d32484f0cd18..000000000000
--- a/dev-db/redis/files/redis-2.8.3-shared.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 388a76f24c96767c831ee7682234fd9f2bc5b9ac
-Author: Johan Bergström <bugs@bergstroem.nu>
-Date: Mon Nov 25 09:17:14 2013 +1100
-
- Use shared jemalloc
-
-diff --git src/Makefile src/Makefile
-index c37549d..77e6255 100644
---- src/Makefile
-+++ src/Makefile
-@@ -26,12 +26,7 @@ PREFIX?=/usr/local
- INSTALL_BIN=$(PREFIX)/bin
- INSTALL=install
-
--# Default allocator
--ifeq ($(uname_S),Linux)
-- MALLOC=jemalloc
--else
-- MALLOC=libc
--endif
-+MALLOC?=jemalloc
-
- # Backwards compatibility for selecting an allocator
- ifeq ($(USE_TCMALLOC),yes)
-@@ -79,9 +74,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
- endif
-
- ifeq ($(MALLOC),jemalloc)
-- DEPENDENCY_TARGETS+= jemalloc
-- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
-- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
-+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE
-+ FINAL_LIBS+= -ljemalloc -ldl
- endif
-
- REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
diff --git a/dev-db/redis/files/redis-3.0.0-sharedlua.patch b/dev-db/redis/files/redis-3.0.0-sharedlua.patch
deleted file mode 100644
index ba983efafc7c..000000000000
--- a/dev-db/redis/files/redis-3.0.0-sharedlua.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-commit fd0fc43f6e0ea45bce0e1a68c1f736e481fc4429
-Author: Johan Bergström <bugs@bergstroem.nu>
-Date: Thu Apr 2 14:33:51 2015 +1100
-
- Use shared LUA
-
-diff --git src/Makefile src/Makefile
-index a88f1d2..f71e7b5 100644
---- src/Makefile
-+++ src/Makefile
-@@ -15,7 +15,7 @@
- release_hdr := $(shell sh -c './mkreleasehdr.sh')
- uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
- OPTIMIZATION?=-O2
--DEPENDENCY_TARGETS=hiredis linenoise lua
-+DEPENDENCY_TARGETS=hiredis linenoise
-
- # Default settings
- STD=-std=c99 -pedantic
-@@ -47,6 +47,7 @@ endif
- FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
- FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
- FINAL_LIBS=-lm
-+FINAL_LIBS+=$(shell pkg-config --libs lua)
- DEBUG=-g -ggdb
-
- ifeq ($(uname_S),SunOS)
-@@ -108,6 +109,7 @@ endif
- REDIS_SERVER_NAME=redis-server
- REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
-+REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o
- REDIS_CLI_NAME=redis-cli
- REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
- REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -162,7 +164,7 @@ endif
-
- # redis-server
- $(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
-- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS)
-+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS)
-
- # redis-sentinel
- $(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME)
diff --git a/dev-db/redis/files/redis.confd b/dev-db/redis/files/redis.confd
deleted file mode 100644
index 07585fa7a116..000000000000
--- a/dev-db/redis/files/redis.confd
+++ /dev/null
@@ -1,20 +0,0 @@
-# Redis user.
-REDIS_USER="redis"
-
-# Redis group.
-REDIS_GROUP="redis"
-
-# Redis configuration file.
-REDIS_CONF="/etc/redis.conf"
-
-# Redis dump directory.
-REDIS_DIR="/var/lib/redis"
-
-# Redis pid file.
-# (Be sure to change the main redis configuration file as well if you change
-# this from the default.)
-REDIS_PID="/var/run/redis/redis.pid"
-
-# Redis options.
-# (Redis expects the first argument to be the configuration file.)
-REDIS_OPTS="${REDIS_CONF}"
diff --git a/dev-db/redis/files/redis.initd-4 b/dev-db/redis/files/redis.initd-4
deleted file mode 100644
index 5c12fdc7c79d..000000000000
--- a/dev-db/redis/files/redis.initd-4
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/sbin/openrc-run
-
-REDIS_DIR=${REDIS_DIR:-/var/lib/redis}
-REDIS_CONF=${REDIS_CONF:-/etc/redis.conf}
-REDIS_OPTS=${REDIS_OPTS:-"${REDIS_CONF}"}
-REDIS_USER=${REDIS_USER:-redis}
-REDIS_GROUP=${REDIS_GROUP:-redis}
-REDIS_TIMEOUT=${REDIS_TIMEOUT:-30}
-
-command=/usr/sbin/redis-server
-pidfile=${REDIS_PID:-/run/redis/redis.pid}
-start_stop_daemon_args="--background --pidfile ${pidfile} --chdir \"${REDIS_DIR}\" --user ${REDIS_USER} --group ${REDIS_GROUP}"
-command_args="${REDIS_OPTS}"
-
-depend() {
- use net localmount logger
- after keepalived
-}
-
-start_pre() {
- checkpath -d -m 0775 -o ${REDIS_USER}:${REDIS_GROUP} $(dirname ${REDIS_PID})
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --exec ${command} \
- --retry ${REDIS_TIMEOUT} \
- --pidfile ${pidfile}
- eend
-}