summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-05-21 22:06:32 -0400
committerKenton Groombridge <concord@gentoo.org>2022-05-21 22:12:56 -0400
commit63692502e6f3b4bb1a2b410f81825479840de2a9 (patch)
tree6dd140e37cd1bbb62bb1c716b396e736704a4331 /dev-db/redis
parentapp-crypt/acme-sh: add selinux USE flag (diff)
downloadgentoo-63692502e6f3b4bb1a2b410f81825479840de2a9.tar.gz
gentoo-63692502e6f3b4bb1a2b410f81825479840de2a9.tar.bz2
gentoo-63692502e6f3b4bb1a2b410f81825479840de2a9.zip
dev-db/redis: add selinux USE flag
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/redis-5.0.14.ebuild7
-rw-r--r--dev-db/redis/redis-6.0.16.ebuild5
-rw-r--r--dev-db/redis/redis-6.2.6.ebuild3
-rw-r--r--dev-db/redis/redis-6.2.7-r1.ebuild3
-rw-r--r--dev-db/redis/redis-7.0.0.ebuild3
5 files changed, 13 insertions, 8 deletions
diff --git a/dev-db/redis/redis-5.0.14.ebuild b/dev-db/redis/redis-5.0.14.ebuild
index a8ec106eeb4d..0d8391f04013 100644
--- a/dev-db/redis/redis-5.0.14.ebuild
+++ b/dev-db/redis/redis-5.0.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc tcmalloc luajit test"
+IUSE="+jemalloc tcmalloc luajit selinux test"
RESTRICT="!test? ( test )"
# Redis does NOT build with Lua 5.2 or newer at this time.
@@ -25,7 +25,8 @@ COMMON_DEPEND="
RDEPEND="
${COMMON_DEPEND}
acct-group/redis
- acct-user/redis"
+ acct-user/redis
+ selinux? ( sec-policy/selinux-redis )"
BDEPEND="
${COMMON_DEPEND}
diff --git a/dev-db/redis/redis-6.0.16.ebuild b/dev-db/redis/redis-6.0.16.ebuild
index 347c229d7386..b5c13c94f4cb 100644
--- a/dev-db/redis/redis-6.0.16.ebuild
+++ b/dev-db/redis/redis-6.0.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,7 @@ SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc ssl systemd tcmalloc test"
+IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -35,6 +35,7 @@ RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
+ selinux? ( sec-policy/selinux-redis )
"
BDEPEND="
diff --git a/dev-db/redis/redis-6.2.6.ebuild b/dev-db/redis/redis-6.2.6.ebuild
index 023aba8e9614..805967d1d7e6 100644
--- a/dev-db/redis/redis-6.2.6.ebuild
+++ b/dev-db/redis/redis-6.2.6.ebuild
@@ -20,7 +20,7 @@ SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc ssl systemd tcmalloc test"
+IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -35,6 +35,7 @@ RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
+ selinux? ( sec-policy/selinux-redis )
"
BDEPEND="
diff --git a/dev-db/redis/redis-6.2.7-r1.ebuild b/dev-db/redis/redis-6.2.7-r1.ebuild
index daabb56d3c64..140726ba8994 100644
--- a/dev-db/redis/redis-6.2.7-r1.ebuild
+++ b/dev-db/redis/redis-6.2.7-r1.ebuild
@@ -23,7 +23,7 @@ SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc ssl systemd tcmalloc test"
+IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -38,6 +38,7 @@ RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
+ selinux? ( sec-policy/selinux-redis )
"
BDEPEND="
diff --git a/dev-db/redis/redis-7.0.0.ebuild b/dev-db/redis/redis-7.0.0.ebuild
index 698a438da0a7..b77a78d5aea1 100644
--- a/dev-db/redis/redis-7.0.0.ebuild
+++ b/dev-db/redis/redis-7.0.0.ebuild
@@ -23,7 +23,7 @@ SRC_URI="https://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+jemalloc ssl systemd tcmalloc test"
+IUSE="+jemalloc selinux ssl systemd tcmalloc test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -38,6 +38,7 @@ RDEPEND="
${COMMON_DEPEND}
acct-group/redis
acct-user/redis
+ selinux? ( sec-policy/selinux-redis )
"
BDEPEND="