summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-02-27 22:49:16 +0100
committerMike Gilbert <floppym@gentoo.org>2019-02-27 17:35:19 -0500
commit0ac6b43b9f88dcc321ae16fac9a3c967fceffa29 (patch)
tree45af8cad4810a9ca64544d71cdf6a3f12b106b5a /dev-db/sqlite
parentdev-db/sqlite: Version bump (3.27.2). (diff)
downloadgentoo-0ac6b43b9f88dcc321ae16fac9a3c967fceffa29.tar.gz
gentoo-0ac6b43b9f88dcc321ae16fac9a3c967fceffa29.tar.bz2
gentoo-0ac6b43b9f88dcc321ae16fac9a3c967fceffa29.zip
dev-db/sqlite: Fix tests with dev-lang/tcl-8.6.9.
Fixes: https://bugs.gentoo.org/675862 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/sqlite-3.27.2-full_archive-tests.patch36
-rw-r--r--dev-db/sqlite/sqlite-3.27.2.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.27.2-full_archive-tests.patch b/dev-db/sqlite/files/sqlite-3.27.2-full_archive-tests.patch
new file mode 100644
index 000000000000..92959579b542
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.27.2-full_archive-tests.patch
@@ -0,0 +1,36 @@
+https://sqlite.org/src/info/29d02bf2fa9ecacb
+
+--- /ext/session/sessionB.test
++++ /ext/session/sessionB.test
+@@ -258,8 +258,7 @@
+ INSERT INTO t2 VALUES('a', 'a', 'a', 'a');
+ } {
+ DELETE FROM t2 WHERE c = 'a';
+-} {
+-}
++} {}
+
+ # INSERT + UPDATE
+ do_patchconcat_test 4.3.4 {
+--- /test/fts3expr4.test
++++ /test/fts3expr4.test
+@@ -68,7 +68,7 @@
+ AND {AND {AND {PHRASE 3 0 *} {PHRASE 3 0 lol+}} {PHRASE 3 0 *}} {PHRASE 3 0 h4h+}
+ }
+
+-do_simple_expr_test 3.3 { * } { }
++do_simple_expr_test 3.3 { * } {}
+ do_simple_expr_test 3.4 { *a } { PHRASE 3 0 a }
+ do_simple_expr_test 3.5 { a*b } { AND {PHRASE 3 0 a+} {PHRASE 3 0 b} }
+ do_simple_expr_test 3.6 { *a*b } { AND {PHRASE 3 0 a+} {PHRASE 3 0 b} }
+--- /test/scanstatus.test
++++ /test/scanstatus.test
+@@ -254,7 +254,7 @@
+ }
+
+ do_execsql_test 4.1.1 { INSERT INTO t1 VALUES(1, 2, 3); }
+-do_scanstatus_test 4.1.2 { }
++do_scanstatus_test 4.1.2 {}
+
+ do_execsql_test 4.2 {
+ CREATE TABLE p1(x PRIMARY KEY);
diff --git a/dev-db/sqlite/sqlite-3.27.2.ebuild b/dev-db/sqlite/sqlite-3.27.2.ebuild
index 570c5a4f74e5..d008a6a8e1b1 100644
--- a/dev-db/sqlite/sqlite-3.27.2.ebuild
+++ b/dev-db/sqlite/sqlite-3.27.2.ebuild
@@ -59,6 +59,7 @@ pkg_setup() {
src_prepare() {
if full_archive; then
eapply "${FILESDIR}/${PN}-3.27.0-full_archive-build.patch"
+ eapply "${FILESDIR}/${PN}-3.27.2-full_archive-tests.patch"
eapply_user