summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-04-19 22:18:42 +0200
committerSam James <sam@gentoo.org>2022-05-16 05:22:05 +0000
commit228063befae0e81b19ba223de07758db4c94aaa7 (patch)
treea95aaaa8ff4130bded0223b637fc5e20a5b6bc55 /dev-db/sqlmap
parentdev-util/unicorn: enable py3.8; add pypi remote-id (diff)
downloadgentoo-228063befae0e81b19ba223de07758db4c94aaa7.tar.gz
gentoo-228063befae0e81b19ba223de07758db4c94aaa7.tar.bz2
gentoo-228063befae0e81b19ba223de07758db4c94aaa7.zip
dev-db/sqlmap: version bump 1.6.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/25118 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/sqlmap')
-rw-r--r--dev-db/sqlmap/Manifest1
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.4.ebuild60
-rw-r--r--dev-db/sqlmap/sqlmap-9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-db/sqlmap/Manifest b/dev-db/sqlmap/Manifest
index c37adc6febf9..08c256535553 100644
--- a/dev-db/sqlmap/Manifest
+++ b/dev-db/sqlmap/Manifest
@@ -1 +1,2 @@
DIST sqlmap-1.6.2.tar.gz 7258723 BLAKE2B cc972eda5351683904e4c9d4f7e0ab9c127c22de597397e976060808812032b2041f68ab2d737784e499a20a7ca930167427390ca178269d744ee71738e5c270 SHA512 a3057486f5096fb2a242296b4ceeb1c500246fbd322c3e52f71e72cd91d1c676ca6f7746becf887625e45d0b14443a669410b28bd6a995124a6e8006c4534976
+DIST sqlmap-1.6.4.tar.gz 7203746 BLAKE2B 8e55805a59dbc7fa4a4be03d5edf34160858e624047dafe63d6280bfb59c83fef0bfe3f74b775adad3cbe3be312dad166c79c758fe18418d32788c22b2233d16 SHA512 304c8213ae4b1858066765fa5e6409e97ac90de46b319683e7daf6c89f610de04cac400a7044633aeb014648b7b57c880c3a2646b40049b93f84a626c12994d2
diff --git a/dev-db/sqlmap/sqlmap-1.6.4.ebuild b/dev-db/sqlmap/sqlmap-1.6.4.ebuild
new file mode 100644
index 000000000000..a10a6cfcb7aa
--- /dev/null
+++ b/dev-db/sqlmap/sqlmap-1.6.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 python-single-r1 wrapper
+
+DESCRIPTION="An automatic SQL injection and database takeover tool"
+HOMEPAGE="https://sqlmap.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
+else
+ SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# sqlmap (GPL-2+)
+# ansitrm (BSD)
+# beautifulsoup (BSD)
+# bottle (MIT)
+# chardet (LGPL-2.1+)
+# clientform (BSD)
+# colorama (BSD)
+# fcrypt (BSD-2)
+# identitywaf (MIT)
+# keepalive (LGPL-2.1+)
+# magic (MIT)
+# multipartpost (LGPL-2.1+)
+# ordereddict (MIT)
+# prettyprint (BSD-2)
+# pydes (public-domain)
+# six (MIT)
+# socks (BSD)
+# termcolor (BSD)
+# wininetpton (public-domain)
+LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( doc/ README.md )
+
+src_install () {
+ einstalldocs
+
+ insinto /usr/share/${PN}/
+ doins -r *
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
+
+ newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
+}
diff --git a/dev-db/sqlmap/sqlmap-9999.ebuild b/dev-db/sqlmap/sqlmap-9999.ebuild
index 7b33e4568b15..a10a6cfcb7aa 100644
--- a/dev-db/sqlmap/sqlmap-9999.ebuild
+++ b/dev-db/sqlmap/sqlmap-9999.ebuild
@@ -23,7 +23,7 @@ fi
# ansitrm (BSD)
# beautifulsoup (BSD)
# bottle (MIT)
-# charder (LGPL-2.1+)
+# chardet (LGPL-2.1+)
# clientform (BSD)
# colorama (BSD)
# fcrypt (BSD-2)