summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-02 09:14:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-02 09:14:03 +0000
commit1d5a3bce99c5a259801a472c9387523e082aaa04 (patch)
treec7c643707e010f42a68fb944438599ae3b6c735e /dev-db/timescaledb
parentdev-db/citus: Bump (diff)
downloadgentoo-1d5a3bce99c5a259801a472c9387523e082aaa04.tar.gz
gentoo-1d5a3bce99c5a259801a472c9387523e082aaa04.tar.bz2
gentoo-1d5a3bce99c5a259801a472c9387523e082aaa04.zip
dev-db/timescaledb: Bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest2
-rw-r--r--dev-db/timescaledb/timescaledb-2.0.2.ebuild66
-rw-r--r--dev-db/timescaledb/timescaledb-2.1.0.ebuild66
3 files changed, 134 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index 97a1e06e875f..21e15e51a375 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1 +1,3 @@
DIST timescaledb-2.0.1.tar.gz 2226320 BLAKE2B 0bd5011e30d6c0d5ac11b78ddf6650044f35d720317213bd0437a43e0421953708d3d69b6933a821d255b183bb72b1c5e34ff88223790266daf7af3cf21f2de2 SHA512 84e9c7da3f0fc6740eb0555bbd92f5511ceef4868fb1952650f9499f3054a4d2be59b3a042b17bf655155c9f9c1de82b6b4fb302bdad7ffbe893ed901adcefc0
+DIST timescaledb-2.0.2.tar.gz 2237429 BLAKE2B 58c5e68daf5a3c1fade48b2ce8f625496ee3c58be38c573c883e319eb0084064d243270ac839e4bdd1ce3c865fc6b916c7869232b995529d8aca77851a0c7a79 SHA512 26ce25e4d833810cdd99691f3b8a4d0c26655b2efeba7c25d5daaaf2d1aabd8f96a421a771da9c5b6cf29af66ddcab39f3881d40364e25c101ea691e4ec61116
+DIST timescaledb-2.1.0.tar.gz 2527250 BLAKE2B 6f257c4b1afc0869c8e309f9b3080dbcdda4b50debc1a5b3848b9d6e59744ff52902b475aca0bc8820aa2edebe9847d62e500a8cd19f7ab8050d9586d95d3a66 SHA512 53fddb9fe4c4ab51ebc020e90eea5b032b41259d3bd45e8a03a86451acd7f8864b5a6ecba1b82b7c78e230f62cfddf1da75ff27e6629ad5fe8178839ac411ce4
diff --git a/dev-db/timescaledb/timescaledb-2.0.2.ebuild b/dev-db/timescaledb/timescaledb-2.0.2.ebuild
new file mode 100644
index 000000000000..9e97e6124c15
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}
diff --git a/dev-db/timescaledb/timescaledb-2.1.0.ebuild b/dev-db/timescaledb/timescaledb-2.1.0.ebuild
new file mode 100644
index 000000000000..54ea9700b357
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 11 12 13 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}