summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-11-28 06:45:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-11-28 06:45:58 +0000
commit633380bbbfb5dddab9063793e162e80464ab64f5 (patch)
tree9d6ea5f89aff71f2d6a65e0e47ae1ba65bd021ae /dev-db/timescaledb
parentmedia-libs/harfbuzz: Stabilize 3.1.1 arm64, #821970 (diff)
downloadgentoo-633380bbbfb5dddab9063793e162e80464ab64f5.tar.gz
gentoo-633380bbbfb5dddab9063793e162e80464ab64f5.tar.bz2
gentoo-633380bbbfb5dddab9063793e162e80464ab64f5.zip
dev-db/timescaledb: Bump to 2.5.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.5.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index f031319b9686..3d9fa0d69cac 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -6,3 +6,4 @@ DIST timescaledb-2.2.1.tar.gz 2637225 BLAKE2B 4ab37bb5c45a3f7550c2694c8757fff3e8
DIST timescaledb-2.3.1.tar.gz 2699256 BLAKE2B 5949245d4a2bf52558b3f646d3723b0571745226fcc0de236c21ad7f32316eaeb0780aa94f8ccacd420cd0b0e47c8e048172b9f9355cf01797398b7f2fc85a6a SHA512 431f716ecd98504ce8e5b85e6fd10bf87ed39aac0244b7e968383537caae965ece09f016fed8ea010f5d42b392aed2d75b012deafd807d107f3dc75cbde287ec
DIST timescaledb-2.4.1.tar.gz 2401410 BLAKE2B 752d484b03a59cde22f295d47a90d05bfc0674428dd2d03152dbf6604e10c0fb6780815666f65f4d2df58075f7911636c13a671504eed78642e211ceda8aba3d SHA512 54baced28eb20aa14c78605ce7828f7c48210125d9193c3e1c88e9ae81616b2baf37a1eb97c5eb0ddc9b6820d534d134ad047f3c7ace374e29191a42142f35a1
DIST timescaledb-2.4.2.tar.gz 2409324 BLAKE2B 387f8ba3f446af227e7bd578177a6391c6ad6b1f889eb305499dc420805ad84041bf09b48cf7087727a5d111a7b374a5a5b9b83c0c97a69dc09d9c2c5d3ee9ca SHA512 56a0ff981e7374e2845d949c5bde2f157063b36cb7f9c54c6627c35ae8a8a5e5a3637fb66c6fd5c61a25b86f80a204ab7a6071b9705646bfee6a9b252c805b2d
+DIST timescaledb-2.5.0.tar.gz 2737786 BLAKE2B 3c3af86e016e2a2d2484b65cd7754eb0c2561358a51f2d3887aa9c0fce8ec2e8598751423b2858fa25955a0744a32ac40c40766d4abe91751701fe053e6c7498 SHA512 fcb3130b472d7ebbaabcce6259b5585ceff2c2b39abeb68f13f2bf5e715afb6a5ccab8534ea9e8eea0c7aef31045680e17f48ff46465d7e693450f1cd77001e4
diff --git a/dev-db/timescaledb/timescaledb-2.5.0.ebuild b/dev-db/timescaledb/timescaledb-2.5.0.ebuild
new file mode 100644
index 000000000000..122047bcdea4
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.5.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 12 13 14 )
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}
+ dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}