summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-29 10:44:30 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 16:10:08 -0400
commit4083dff8d9f15693386d82e0537af29981122bd3 (patch)
tree1618b287a68f25a067b6c2c982a1125b36285cf3 /dev-db/tokyocabinet
parentapp-text/tokyodystopia: bump EAPI and add EPREFIX (diff)
downloadgentoo-4083dff8d9f15693386d82e0537af29981122bd3.tar.gz
gentoo-4083dff8d9f15693386d82e0537af29981122bd3.tar.bz2
gentoo-4083dff8d9f15693386d82e0537af29981122bd3.zip
dev-db/tokyocabinet: drop EAPI=2 ebuild
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild
deleted file mode 100644
index 3296d12046cb..000000000000
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils autotools
-
-DESCRIPTION="A library of routines for managing a database"
-HOMEPAGE="http://fallabs.com/tokyocabinet/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="debug doc examples"
-
-DEPEND="sys-libs/zlib
- app-arch/bzip2"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
- sed -i \
- -e "/ldconfig/d" \
- -e "/DATADIR/d" Makefile.in || die
- # cflags fix - remove -O2 at end of line and -fomit-frame-pointer
- sed -i -e 's/-O3"$/"/' configure.in || die
- sed -i -e 's/-fomit-frame-pointer//' configure.in || die
- # flag only works on x86 derivatives, remove everywhere else
- if ! use x86 && ! use amd64; then sed -i -e 's/ -minline-all-stringops//' configure.in; fi
- eautoreconf
-}
-
-src_configure() {
- # we use the "fastest" target without the -O3
- econf $(use_enable debug) --enable-off64 --enable-fastest
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-
- if use examples; then
- insinto /usr/share/${PF}/example
- doins example/* || die "Install failed"
- fi
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/* || die "Install failed"
- fi
-}
-
-src_test() {
- emake -j1 check || die "Tests failed"
-}