summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-06-15 14:52:44 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-06-15 14:52:44 +0200
commit174b2de43476c3e156e8281cb4b456f75552035a (patch)
tree4c01c80216173ba2172bceca09e6314ffe519e0b /dev-db
parentapp-emulation/virtualbox: Revbumps to remove uage of whoami (diff)
downloadgentoo-174b2de43476c3e156e8281cb4b456f75552035a.tar.gz
gentoo-174b2de43476c3e156e8281cb4b456f75552035a.tar.bz2
gentoo-174b2de43476c3e156e8281cb4b456f75552035a.zip
dev-db/pg_activity: version bump to 2.3.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-2.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 57114c5a805f..26ec1d6d9afd 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-2.3.0.tar.gz 283467 BLAKE2B 2f480ebd8b628718a33a772a942e2abfdd91a20cbde2c4aad41d150414bf8cec4478bab475702cd0a31f66af535b373ea706f9b05f948637410a6ad1ef6dcfd4 SHA512 972abddb1871bf4d0b74778ea988f024f33f38335597543d30a2d7549165269a4e5269b1cb649449ff92491501a70b7e3b6b930a154a7ff377e62f7231abb9a7
+DIST pg_activity-2.3.1.tar.gz 283216 BLAKE2B d8a7382f3343b0e339e69e31a19bdc628d3c79ff12b037500f67900c6875272dffec3fdda8f51e20dd05a2e4e917cdac1562a8e2a9e80362358ba43ba3bdf44f SHA512 26c29ec1701cd2eead8314d2a4df247557164231c53323fb3bed12fbf346e14247addfa508af94cee685a2f0084a26c26118896c4c3395e41fb0eee4a4da2d27
diff --git a/dev-db/pg_activity/pg_activity-2.3.1.ebuild b/dev-db/pg_activity/pg_activity-2.3.1.ebuild
new file mode 100644
index 000000000000..a7e75c7ee86b
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-2.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}