summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-10 18:53:16 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-10 18:53:46 +0900
commit17568c569456a7cdbec5420d3f6ca6938f253ef1 (patch)
tree3509891b66ebf030af1d847ccf10c8fdc21b7c46 /dev-db
parentdev-db/qdbm: update to EAPI 7 (diff)
downloadgentoo-17568c569456a7cdbec5420d3f6ca6938f253ef1.tar.gz
gentoo-17568c569456a7cdbec5420d3f6ca6938f253ef1.tar.bz2
gentoo-17568c569456a7cdbec5420d3f6ca6938f253ef1.zip
dev-db/qdbm: fix configure
Closes: https://bugs.gentoo.org/718664 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/qdbm/files/qdbm-configure.patch139
1 files changed, 122 insertions, 17 deletions
diff --git a/dev-db/qdbm/files/qdbm-configure.patch b/dev-db/qdbm/files/qdbm-configure.patch
index 364c5c9f653e..4eb62949f32f 100644
--- a/dev-db/qdbm/files/qdbm-configure.patch
+++ b/dev-db/qdbm/files/qdbm-configure.patch
@@ -18,10 +18,13 @@
#================================================================
--- a/configure.in
+++ b/configure.in
-@@ -20,15 +20,6 @@
- LD="ld"
- AR="ar"
-
+@@ -17,17 +17,6 @@
+ MYDEFS=""
+ MYOPTS=""
+ MGWLIBS=""
+-LD="ld"
+-AR="ar"
+-
-# Building paths
-pathtmp="$PATH"
-PATH="$HOME/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin"
@@ -30,16 +33,56 @@
-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
-CPATH="$HOME/include:/usr/local/include:$CPATH"
-export PATH LIBRARY_PATH LD_LIBRARY_PATH CPATH
--
- #================================================================
+
+@@ -186,19 +175,15 @@
+ then
+ MYOPTS="-O1 -fno-omit-frame-pointer -fno-force-addr"
+ fi
+-if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+ MYOPTS="-O1 -fno-omit-frame-pointer -fno-force-addr"
+ fi
+
+ # Linker
+-printf 'checking for ld... '
+-if which ld | grep '/ld$' > /dev/null 2>&1
++AC_CHECK_TOOL(LD, ld, no)
++if test "$LD" = "no"
+ then
+- LD=`which ld`
+- printf '%s\n' "$LD"
+-else
+- printf 'no\n'
+ if test "$isnowarn" != "yes"
+ then
+ printf '#================================================================\n' 1>&2
+@@ -208,13 +193,9 @@
+ fi
+
+ # Archiver
+-printf 'checking for ar... '
+-if which ar | grep '/ar$' > /dev/null 2>&1
++AC_CHECK_TOOL(AR, ar, no)
++if test "$AR" = "no"
+ then
+- AR=`which ar`
+- printf '%s\n' "$AR"
+-else
+- printf 'no\n'
+ if test "$isnowarn" != "yes"
+ then
+ printf '#================================================================\n' 1>&2
--- a/java/configure.in
+++ b/java/configure.in
-@@ -25,15 +25,6 @@
+@@ -23,16 +23,6 @@
+ JAVARUN="java"
+ MYDEFS=""
MYOPTS=""
- LD="ld"
-
+-LD="ld"
+-
-# Building paths
-pathtmp="$PATH"
-PATH="$HOME/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin"
@@ -48,10 +91,32 @@
-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
-CPATH="$HOME/include:/usr/local/include:$CPATH"
-export PATH LIBRARY_PATH LD_LIBRARY_PATH CPATH
--
- #================================================================
+
+@@ -162,19 +152,15 @@
+ then
+ MYOPTS="-O1"
+ fi
+-if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+ MYOPTS="-O1"
+ fi
+
+ # Linker
+-printf 'checking for ld... '
+-if which ld | grep '/ld$' > /dev/null 2>&1
++AC_CHECK_TOOL(LD, ld, no)
++if test "$LD" = "no"
+ then
+- LD=`which ld`
+- printf '%s\n' "$LD"
+-else
+- printf 'no\n'
+ printf '#================================================================\n' 1>&2
+ printf '# WARNING: ld is not found in PATH.\n' 1>&2
+ printf '#================================================================\n' 1>&2
--- a/perl/configure.in
+++ b/perl/configure.in
@@ -5,15 +5,6 @@
@@ -72,10 +137,13 @@
then
--- a/plus/configure.in
+++ b/plus/configure.in
-@@ -19,15 +19,6 @@
- LD="ld"
- AR="ar"
-
+@@ -16,17 +16,6 @@
+ TARGETS="all"
+ MYDEFS=""
+ MYOPTS=""
+-LD="ld"
+-AR="ar"
+-
-# Building paths
-pathtmp="$PATH"
-PATH="$HOME/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin"
@@ -84,10 +152,47 @@
-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
-CPATH="$HOME/include:/usr/local/include:$CPATH"
-export PATH LIBRARY_PATH LD_LIBRARY_PATH CPATH
--
- #================================================================
+
+@@ -75,32 +64,24 @@
+ then
+ MYOPTS="-O1"
+ fi
+-if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++if $CXX --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+ MYOPTS="-O1"
+ fi
+
+ # Linker
+-printf 'checking for ld... '
+-if which ld | grep '/ld$' > /dev/null 2>&1
++AC_CHECK_TOOL(LD, ld, no)
++if test "$LD" = "no"
+ then
+- LD=`which ld`
+- printf '%s\n' "$LD"
+-else
+- printf 'no\n'
+ printf '#================================================================\n' 1>&2
+ printf '# WARNING: ld is not found in PATH.\n' 1>&2
+ printf '#================================================================\n' 1>&2
+ fi
+
+ # Archiver
+-printf 'checking for ar... '
+-if which ar | grep '/ar$' > /dev/null 2>&1
++AC_CHECK_TOOL(AR, ar, no)
++if test "$AR" = "no"
+ then
+- AR=`which ar`
+- printf '%s\n' "$AR"
+-else
+- printf 'no\n'
+ printf '#================================================================\n' 1>&2
+ printf '# WARNING: ar is not found in PATH.\n' 1>&2
+ printf '#================================================================\n' 1>&2
--- a/ruby/configure.in
+++ b/ruby/configure.in
@@ -5,15 +5,6 @@