summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-06-26 14:46:23 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-06-26 14:47:01 +0200
commitbb493ec8947380b333f3923a465701f01fb9de99 (patch)
treebacb17005b70d280870810a5aed19bc0cf941ccf /dev-db
parentmail-client/thunderbird: update patchset to fix libcxx compat (diff)
downloadgentoo-bb493ec8947380b333f3923a465701f01fb9de99.tar.gz
gentoo-bb493ec8947380b333f3923a465701f01fb9de99.tar.bz2
gentoo-bb493ec8947380b333f3923a465701f01fb9de99.zip
dev-db/mysqltuner: add 1.9.9
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysqltuner/Manifest1
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.9.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/Manifest b/dev-db/mysqltuner/Manifest
index c100f545074f..2904f5b20e8c 100644
--- a/dev-db/mysqltuner/Manifest
+++ b/dev-db/mysqltuner/Manifest
@@ -1 +1,2 @@
DIST mysqltuner-1.8.3.tar.gz 254525 BLAKE2B 7fa1fe24ab454aa15a03e62410e08988a4a0d3ac9b1e4df0219a67bffa4d6113d8c89d6f93f8e6d08a35ecc4bdbf5c0148d8e53138f05a5c22899ecca98b3614 SHA512 965ad0204cb449aa113bf1880a91468d48467c84e7d42ac8f12e7ee4035e49dc7cb191d2b11b6e5b084a60c3857e92ac4d1bef63f688538f3468fda32304a702
+DIST mysqltuner-1.9.9.tar.gz 225048 BLAKE2B 5c22ecbe3ab8ab2ad8712c6cbdfbc6bb182e6211d7894c2dc10c68b5b31f74f7512747c983844ba6ce9e12e422f510e4e68a18e85e29f443424e4dfa7055e1f7 SHA512 9373fcbcf514a989126b100739a87d711b4c2081e2608b4576d0ab88590ffd85fae57f1587e1d9f44cf0d89baa92eeb9115db2c4c6c491b701e965de7a549fa0
diff --git a/dev-db/mysqltuner/mysqltuner-1.9.9.ebuild b/dev-db/mysqltuner/mysqltuner-1.9.9.ebuild
new file mode 100644
index 000000000000..04400f30bd2b
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.9.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="MySQLTuner-perl"
+
+DESCRIPTION="Makes recommendations for increased performance and stability for MySQL"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ newbin mysqltuner.pl mysqltuner
+ dodoc {CONTRIBUTING,INTERNALS,USAGE}.md
+ einstalldocs
+
+ # Passwords and vulnerabilities are meant to be fed to the script uncompressed.
+ dodoc basic_passwords.txt vulnerabilities.csv
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}