summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2020-07-18 05:26:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2020-07-18 05:26:31 +0000
commitc363b522cb4d112b43dd97efb6f6c0ebff712ecd (patch)
tree809e687e291070d2966edfbcadbc10b955bfa748 /dev-db
parentdev-perl/Net-DNS-SEC: Drop m68k re bug #665088 (diff)
downloadgentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.tar.gz
gentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.tar.bz2
gentoo-c363b522cb4d112b43dd97efb6f6c0ebff712ecd.zip
dev-db/repmgr: Bump
Older versions don't build with newer postgres Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/repmgr/Manifest1
-rw-r--r--dev-db/repmgr/repmgr-5.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/repmgr/Manifest b/dev-db/repmgr/Manifest
index e60b7b71d26f..ca615167c8da 100644
--- a/dev-db/repmgr/Manifest
+++ b/dev-db/repmgr/Manifest
@@ -1,2 +1,3 @@
DIST repmgr-3.0.1.tar.gz 91724 BLAKE2B be0ac2d54dbaae7a45abaa90ed1a851e22f05a1bb0969a1c5d95e58d7c3f89513cc47555b77cc57bb5cd5baf60c21c9c44375363a757510f07b111ec78f87441 SHA512 5655745df18132ee53ff36f80b3a2bb8caa6cedd8091350464cf343386baa31c47d46b25c171dda0fd1f4c3402babea9864f4557a10659111449a2eb2e1fa2b9
DIST repmgr-3.3.2.tar.gz 162107 BLAKE2B b1029297fa548241dc5d58bcdcffc0a6f749725eba2d3c7d2cb70b1f46a96b491dc27deb7baf8459e91eae9663df000a1713e80f05e7e0e39afc020b4136c9a4 SHA512 98fba8fc0d9074e496c66762dbec45734fe279f39c9c51adb3e66dca929ac37f66a609789c8c658545856fd81f5afc5b35f6b5e389e52bce8c04ce8c52acd8dd
+DIST repmgr-5.1.0.tar.gz 426487 BLAKE2B 25157923f94b8bd27a2b57796f701e89e7d9acfc8dabc4368640068d5926934e5688b27147ae94b4bee7bad54d59353927b5b70cf5590c554c4eef35fadf29b9 SHA512 9fa8a43ee3920269d1c1d2e619939eb68cb7ba79effe11e87dd67c594bacfcde609949322ce968df328f3913111f27d0ebe2f7742a72e21f3df97b0e05c56cc7
diff --git a/dev-db/repmgr/repmgr-5.1.0.ebuild b/dev-db/repmgr/repmgr-5.1.0.ebuild
new file mode 100644
index 000000000000..06a26ac1e9b5
--- /dev/null
+++ b/dev-db/repmgr/repmgr-5.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils multilib
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-db/postgresql-9.3[server,static-libs]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ export PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+ PGBASEDIR=/usr/$(get_libdir)/postgresql-${PGSLOT}
+ PGBINDIR=${PGBASEDIR}/bin/
+ PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
+ dodir $PGCONTRIB $PGBINDIR
+ dosym $PGBINDIR/repmgr /usr/bin/repmgr${PGSLOT//.}
+ dosym $PGBINDIR/repmgrd /usr/bin/repmgrd${PGSLOT//.}
+ dodoc CREDITS HISTORY COPYRIGHT *.md
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}