summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-16 19:32:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-18 19:03:51 +0200
commitc57f1da553a4f67465978162850ecd21864ea82c (patch)
tree8d5426f99f2de1f24438902c5db1da48c99d3e66 /dev-db
parentx11-misc/birdtray: bump to 1.8.1 + fix Qt 5.15 support (diff)
downloadgentoo-c57f1da553a4f67465978162850ecd21864ea82c.tar.gz
gentoo-c57f1da553a4f67465978162850ecd21864ea82c.tar.bz2
gentoo-c57f1da553a4f67465978162850ecd21864ea82c.zip
dev-db/libdbi-drivers: Drop 0.9.0 (r0)
Closes: https://bugs.gentoo.org/704418 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
deleted file mode 100644
index 6f3b490144fd..000000000000
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.9.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils autotools ltprune
-
-DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
-HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
-LICENSE="LGPL-2.1"
-
-IUSE="doc firebird mysql oci8 postgres +sqlite static-libs"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 ~sparc x86"
-SLOT=0
-REQUIRED_USE="|| ( mysql postgres sqlite firebird oci8 )"
-RESTRICT="firebird? ( bindist )"
-
-RDEPEND="
- >=dev-db/libdbi-0.9.0
- firebird? ( dev-db/firebird )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- sqlite? ( dev-db/sqlite:3 )
-"
-DEPEND="${RDEPEND}
- doc? ( app-text/openjade )
-"
-
-DOCS="AUTHORS ChangeLog NEWS README README.osx TODO"
-
-pkg_setup() {
- use oci8 && [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
-}
-
-src_prepare() {
- #"${FILESDIR}"/${P}-fix-ac-macro.patch \
- #"${FILESDIR}"/${PN}-0.8.3-oracle-build-fix.patch \
- #"${FILESDIR}"/${PN}-0.8.3-firebird-fix.patch
- epatch \
- "${FILESDIR}"/${PN}-0.9.0-doc-build-fix.patch
- eautoreconf
-}
-
-src_configure() {
- local myconf=""
- # WARNING: the configure script does NOT work correctly
- # --without-$driver does NOT work
- # so do NOT use `use_with...`
- # Future additions:
- # msql
- # freetds
- # ingres
- # db2
- use mysql && myconf+=" --with-mysql"
- use postgres && myconf+=" --with-pgsql"
- use sqlite && myconf+=" --with-sqlite3"
- use firebird && myconf+=" --with-firebird"
- if use oci8; then
- [[ -z "${ORACLE_HOME}" ]] && die "\$ORACLE_HOME is not set!"
- myconf+=" --with-oracle-dir=${ORACLE_HOME} --with-oracle"
- fi
-
- econf \
- $(use_enable doc docs) \
- $(use_enable static-libs static) \
- --with-dbi-libdir=/usr/$(get_libdir) \
- ${myconf}
-}
-
-src_test() {
- if [[ -z "${WANT_INTERACTIVE_TESTS}" ]]; then
- ewarn "Tests disabled due to interactivity."
- ewarn "Run with WANT_INTERACTIVE_TESTS=1 if you want them."
- return 0
- fi
- einfo "Running interactive tests"
- emake check
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-}