summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:11:42 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:05 +0000
commitdec775036c8ee6182f6691da7fde466c67759770 (patch)
tree35e616e84035ab9518af5b09a5699a069f548cdb /dev-db
parentapp-misc/cdircmp: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-dec775036c8ee6182f6691da7fde466c67759770.tar.gz
gentoo-dec775036c8ee6182f6691da7fde466c67759770.tar.bz2
gentoo-dec775036c8ee6182f6691da7fde466c67759770.zip
dev-db/tora: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tora/tora-3.2-r1.ebuild6
-rw-r--r--dev-db/tora/tora-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-db/tora/tora-3.2-r1.ebuild b/dev-db/tora/tora-3.2-r1.ebuild
index b13394c1db8c..31c8b8668110 100644
--- a/dev-db/tora/tora-3.2-r1.ebuild
+++ b/dev-db/tora/tora-3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -68,8 +68,8 @@ src_configure() {
-DWANT_INTERNAL_LOKI=OFF
-DWANT_INTERNAL_QSCINTILLA=OFF
-DWANT_RPM=OFF
- -DLOKI_LIBRARY="$(pkg-config --variable=libdir ferrisloki)/libferrisloki.so"
- -DLOKI_INCLUDE_DIR="$(pkg-config --variable=includedir ferrisloki)/FerrisLoki"
+ -DLOKI_LIBRARY="$($(tc-getPKG_CONFIG) --variable=libdir ferrisloki)/libferrisloki.so"
+ -DLOKI_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --variable=includedir ferrisloki)/FerrisLoki"
$(cmake-utils_use_find_package doc Doxygen)
-DENABLE_ORACLE=$(usex oracle)
-DUSE_PCH=OFF
diff --git a/dev-db/tora/tora-9999.ebuild b/dev-db/tora/tora-9999.ebuild
index 14472612ed8f..1aa682ceab18 100644
--- a/dev-db/tora/tora-9999.ebuild
+++ b/dev-db/tora/tora-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -63,8 +63,8 @@ src_configure() {
-DWANT_INTERNAL_LOKI=OFF
-DWANT_INTERNAL_QSCINTILLA=OFF
-DWANT_RPM=OFF
- -DLOKI_LIBRARY="$(pkg-config --variable=libdir ferrisloki)/libferrisloki.so"
- -DLOKI_INCLUDE_DIR="$(pkg-config --variable=includedir ferrisloki)/FerrisLoki"
+ -DLOKI_LIBRARY="$($(tc-getPKG_CONFIG) --variable=libdir ferrisloki)/libferrisloki.so"
+ -DLOKI_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --variable=includedir ferrisloki)/FerrisLoki"
$(cmake-utils_use_find_package doc Doxygen)
-DENABLE_ORACLE=$(usex oracle)
-DUSE_PCH=$(usex pch)